Frage Wie deaktiviere ich den Konsolen-Bildschirmschoner von Linux systemweit?


Ich habe einen Ubuntu-Server, der im Textmodus hochfährt. Es ist selten ein Bildschirm oder eine Tastatur daran angeschlossen, aber wenn ich einen Bildschirm anschließe, muss ich normalerweise auch eine Tastatur anbringen, weil der Bildschirmschoner im Darmmonitor-Modus eingeschaltet ist und ich muss einen Schlüssel drücken, um zu sehen, was ist geht weiter.

Ich bin mir bewusst, dass der Setterm Befehl dies deaktivieren kann, aber es ist eine Sache pro Sitzung. Wie kann ich es so einrichten, dass der Computer den Bildschirm im Textmodus niemals ausblendet, selbst wenn er zum ersten Mal gestartet wird und an der Login-Eingabeaufforderung sitzt?


41
2018-05-01 16:57


Ursprung


Scheint gut bei askubuntu beantwortet zu werden: askubuntu.com/questions/138918/ ... - Roy
Ich schrieb über zwei verschiedene Ansätze, die ich für verschiedene RHEL-Distributionen benötigte. Einer von ihnen kann dir mit Ubuntu helfen: superuser.com/a/1004931/197972 - David C.


Antworten:


Das Konsolen-Werkzeuge Paket ermöglicht die Kontrolle von Konsolenoptionen.

Um die Bildschirmausblendung und das Ausschalten auszuschalten, legen Sie fest BLANK_TIME und POWERDOWN_TIME zu 0 im /etc/console-tools/config. Wenn Sie die Konfigurationsdatei nicht ändern möchten, können Sie denselben Effekt erzielen, indem Sie eine neue Datei erstellen /etc/console-tools/config.d mit folgendem Inhalt:

BLANK_TIME=0
POWERDOWN_TIME=0

Der Name der Datei in config.d muss ausschließlich aus Groß- und Kleinbuchstaben, Ziffern, Unterstrichen und Bindestrichen bestehen.


23
2018-05-01 19:43



Woher weißt du das? Ich habe den ganzen Morgen nach dem Internet gesucht und nach der Dokumentation für / etc / console-tools gesucht und konnte keine finden. - raldi
Wort der Warnung mit diesem: Ich installierte Konsolen-Tools auf Ubuntu-Server 12.04, tat die obige Konfiguration und es tankte es vollständig ... Nicht sicher, was ich falsch gemacht habe, aber wenn es mit jemand anderem passiert (und Sie sind Mist auf Servern wie ich!), booten zu erholen -> root prompt -> mount -o remount, rw / -> apt-get entferne konsole-tools -> reboot - BaronVonKaneHoffen


Oder Sie verwenden / etc / kbd / config zum Einrichten (hängt von Ihrem System ab, was installiert ist)

BLANK_TIME=0
BLANK_DPMS=off

17
2018-01-29 06:27



Was starte ich neu, wenn ich die KBD-Konfiguration ändere? - Frodik
Scheint, /etc/init.d/kbd neu zu laden sein - Vincent
Ich habe das in einer neuen Installation von Ubuntu Server 10.04.4 und 12.04.1 versucht, und es funktionierte nicht in beiden. - Prof. Moriarty
Auf welche Distributionen bezieht sich dies? - Michael Hampton♦
Dies funktioniert auf Debian 6 und 7. Diese Konfigurationsdatei setzt BLANK_TIME=30 standardmäßig. - basic6


Der Parameter wird über die Kernel-Kommandozeile gesteuert, Setterm ändert lediglich die Laufzeiteinstellungen. Um es systemweit zu deaktivieren, können Sie Ihre Kernel-Boot-Befehlszeile ändern, indem Sie sie mit "consoleblank = 0" in Ihrer Boot-Konfiguration (grub / lilo) anhängen.

Wenn etwas während des Boot-Setterm es ist dann wird es den Wert überschreiben.


15
2017-10-14 18:45



Wie gesehen bei superuser.com/questions/152347/ ... ! - codehead
Mit grub2 könnte es in / etc / default / grub hinzugefügt werden GRUB_CMDLINE_LINUX_DEFAULT="consoleblank=0" und dann grub config mit aktualisieren grub[2]-mkconfig -o /boot/grub/grub.cfg. Oder es könnte in die integrierte Kernel-Befehlszeile eingebettet werden, während der Kernel manuell konfiguriert und kompiliert wird. - user3132194


Wenn Sie das hinzufügen setterm Befehl an /etc/rc.local, sollte es für alle virtuellen Konsolen wirksam werden, unabhängig davon, ob ein Benutzer bei ihnen angemeldet ist oder nicht. Z.B.:

setterm -blank 0

7
2018-05-01 18:16



Das scheint in rc.local nicht zu funktionieren. - raldi
Es hat in der Vergangenheit auf RedHat-Systemen funktioniert. Es könnte sein, dass Debian / Ubuntu geladen wird rc.local zu einer etwas anderen Zeit als RH. Das tut mir leid. - James Sneeringer
Funktioniert nicht mit CentOS 6.3. Der Bildschirm wird nach 10 Minuten weiterhin ausgeblendet. - Michael Hampton♦
Ich fand, dass dies für RHEL 5 und 6 (/bin/setterm -blank 0 -powerdown 0 -powersave off), aber nicht für 7. Erfolg oder Misserfolg hängt wahrscheinlich von Ihrer Verteilung und der Konsolenumgebung zu der Zeit ab, in der rc.local ausgeführt wird. - David C.


Wenn Sie ein neueres Ubuntu verwenden, das den Neustart verwendet, können Sie Folgendes verwenden:

for file in /etc/init/tty*.conf; do tty="/dev/`basename $file .conf`"; echo "post-start exec setterm -blank 0 -powersave off >$tty <$tty" | sudo tee -a "$file"; done

Eine kleine Erklärung, was hier vor sich geht:

Neuere Ubuntu-Versionen verwenden Upstart für den Systemstart. Bei Upstart werden die Linux-Konsolen mit Konfigurationsdateien eingerichtet, die in / etc / init gespeichert sind. Der obige Befehl beginnt mit der Iteration über jede dieser Konfigurationsdateien:

for file in /etc/init/tty*.conf;

Der Dateiname der Upstarten-Konfigurationsdatei des tty in $ file wird verwendet, um den Namen des tty-Geräts zu erstellen:

tty="/dev/`basename $file .conf`";

Es wird ein Upstart-Befehl "post-start" erstellt, der "setterm" ausführt, um die Bildschirmausblendung und das Energiesparen nach dem Start des tty zu deaktivieren:

echo "post-start exec setterm -blank 0 -powersave off >$tty <$tty"

Und schließlich wird dieser Befehl an die Upstart-Konfigurationsdatei angehängt:

| sudo tee -a "$file";

4
2017-09-16 22:40



Ihre Antwort wäre viel besser, wenn Sie tatsächlich beschreiben würden, was hier vor sich geht. Es ist nicht sehr nützlich, einfach so einen riesigen Befehl ohne Erklärung zu geben. - Zoredache
@Zoredache du hast Recht, ich habe eine Erklärung hinzugefügt. Danke für die Rückmeldung. - Chris Pick



2
2017-10-14 15:52