Frage Wie behebt man "send-mail: Autorisierung fehlgeschlagen 534 5.7.14"


Ich versuche, E-Mail-Benachrichtigung auf SSH-Root-Login zu erstellen, also musste ich installieren ssmtp und mail Nützlichkeit.

Dann habe ich konfiguriert ssmtp.conf Datei wie folgt:

# Config file for sSMTP sendmail
# The person who gets all mail for userids < 1000
# Make this empty to disable rewriting.
        #root=postmaster
        #Adding  email id to receive system information
root = rootuser@gmail.com
# The place where the mail goes. The actual machine name is required no
# MX records are consulted. Commonly mailhosts are named mail.domain.com
        #mailhub=mail

mailhub = smtp.gmail.com:587

AuthUser=dmymail@gmail.com
AuthPass=plaintext password
UseTLS=YES
UseSTARTTLS=YES

# Where will the mail seem to come from?
rewriteDomain=gmail.com

# The full hostname

hostname = mailserver
# Are users allowed to set their own From: address?
# YES - Allow the user to specify their own From: address
# NO - Use the system generated From: address
FromLineOverride=YES

sowie Revaliases wie folgt:

# Format:       local_account:outgoing_address:mailhub
# Example: root:your_login@your.domain:mailhub.your.domain[:port]

root:rootuser@gmail.com:smtp.gmail.com:25

und ich bekomme diesen Fehler:

send-mail: Authorization failed (534 5.7.14 https://support.google.com/mail/bin/answer.py?answer=78754 ni5sm3908366pbc.83 - gsmtp)
Can't send mail: sendmail process failed with error code 1

aber es hat nicht funktioniert. Bitte helfen Sie mir, das zu klären


52
2017-10-10 17:09


Ursprung


mögliches Duplikat von sSMTP Es ist nicht möglich, Nachrichten über den externen SMTP-Server zu senden - mailq
Habe diesen Fehler letzte Nacht, nachdem es mehrere Monate gearbeitet hat. - ceving
Nachdem ich alle vorgeschlagenen Schritte ausgeführt habe, ist es immer noch fehlgeschlagen, BIS ich einfach mein gmail.com-Passwort geändert habe, obwohl ich das korrekte Passwort verwendet habe ... vielleicht ist es eine neue Google-Sicherheitsvorkehrung - Scott Stensland
@ was war das Heilmittel? Wie hast du es behoben? - 3kstc


Antworten:


Es kann mehr als einen Schritt dauern, um dieses Problem zu beheben

  1. Machen Sie den oben erwähnten Schritt. Melden Sie sich in Ihrem Google E-Mail-Konto an und gehen Sie dann zu diesem Link: https://www.google.com/settings/security/lesssecureapps und legen Sie "Zugriff für weniger sichere Anwendungen" auf ON fest. Testen Sie, ob Ihr Problem behoben ist. Wenn es nicht gelöst ist, wie es für mich nicht war, fahre mit Schritt # 2 fort.

  2. Gehe zu https://support.google.com/accounts/answer/6009563 (Betitelt: "Password incorrect error"). Diese Seite sagt "Es gibt mehrere Gründe, warum Sie möglicherweise einen Fehler" Password incorrect "(aka 534-5.7.14) sehen, wenn Sie sich mit Drittanbieter-Apps bei Google anmelden. In einigen Fällen sogar, wenn Sie Ihr Passwort korrekt eingeben. "  Auf dieser Seite finden Sie 4 Vorschläge, die Sie ausprobieren sollten.

Für mich hat der erste Vorschlag funktioniert:

  • Gehe zu https://g.co/allowaccess von einem anderen Gerät, mit dem Sie zuvor auf Ihr Google-Konto zugegriffen haben, und folgen Sie den Anweisungen.
  • Versuchen Sie, sich erneut von der blockierten App anzumelden.

Es gab drei weitere Vorschläge auf der Seite, die in Schritt 2 gegeben wurden, aber ich habe sie nicht getestet, denn nachdem ich zum redigierten Link gegangen war und den Anweisungen gefolgt war, fing alles an zu arbeiten wie es sollte.


73
2018-03-01 01:42



Option 1. hat für mich funktioniert - Patrick Forget
Zu Ihrer Information: Sie können dies für Ihr gesamtes Unternehmen aktivieren, wenn Sie in den Sicherheitseinstellungen Google Apps für Unternehmen verwenden. - Travis Reeder
+1, Option 1 gefolgt von g.co/allowaccess hat perfekt funktioniert. - greg_data
Nahm mich ein paar Minuten, aber ich fand, wie für die gesamte Organisation in der Admin-Konsole unter aktivieren Sicherheit > Grundeinstellungen > Weniger sichere Apps > Zugriff erzwingen ... was für zusätzliche Verwirrung zeigt "Erweiterte Sicherheitseinstellungen" im Titel (obwohl ich keinen Link zu dieser Seite über die erweiterten Sicherheitseinstellungen finden konnte ...). Verwirrt? Ich auch! - isapir


Das hat für mich funktioniert.

1) Melden Sie sich bei Ihrem Google Mail-Konto an.

2) Gehe zu https://www.google.com/settings/security/lesssecureapps und Aktivieren Sie diese Funktion.

3) Gehe zu https://accounts.google.com/DisplayUnlockCaptcha und klicken Sie auf Weiter.

Dann können Sie Ihre zusätzliche E-Mail-Adresse von Ihrem Google Mail-Konto aus authentifizieren.

Edit: In meinem Fall hat es geholfen, smtp.gmail.com statt smtp.gmail.com:587 zu schreiben.


10
2017-12-29 03:27





Ich hatte das gleiche Problem. Achten Sie darauf, die Sicherheitseinstellungen Ihres Google Mail-Kontos zu überprüfen und "Zugriff für weniger sichere Apps" unter www.google.com/settings/security zu aktivieren.

es wird dann magisch anfangen zu arbeiten.


4
2017-10-14 17:45



Dies ist hilfreich, und ich habe dasselbe Problem behoben, nachdem ich Änderungen an den Sicherheitseinstellungen meines Google Mail-Kontos vorgenommen habe, indem ich unter www.google.com/settings/security "Zugriff für weniger sichere Apps" zugelassen habe. Der zugehörige hilfreiche Link kann gefunden werden Hier


Um dieses Problem zu beheben, müssen Sie Folgendes tun:

1) Melden Sie sich mit dem Webbrowser bei Ihrem Google Mail-Konto an.

2) Klicken Sie auf diesen Link, damit Anwendungen auf Ihr Konto zugreifen können: https://accounts.google.com/b/0/DisplayUnlockCaptcha

3) Klicken Sie auf Weiter, um den Schritt abzuschließen.

4) Versuchen Sie es erneut, um die E-Mail von Ihrem PHP-Skript zu senden. Es sollte funktionieren.


3
2018-01-09 10:31



Dies ist möglicherweise keine wirkliche Antwort für eine Linux-Kerninstallation. Und ich bin mir nicht ganz sicher, ob das nach dem Neustart des Daemon weiter bestehen wird. Du bist besser dran Befolgen Sie die unsicheren App Anweisungen. - Reaces
Es hat für mich funktioniert. Linux-Kerninstallation. Ich habe mich von einem anderen Computer aus angemeldet. - Michal Sokolowski


Dies ist darauf zurückzuführen, dass Google kürzlich eine Richtlinienänderung durchgeführt hat, die in ihren eigenen Worten zu einer Reihe von Änderungen gehört, um die E-Mail-Authentifizierung zu stärken und Praktiken von Google-Produkten zu beenden, die die Authentifizierung beeinträchtigen.

Es werden viele Optionen vorgeschlagen, wie zum Beispiel die Ports für den SMTP-Server zu ändern, die Option "Weniger sichere Apps zulassen" auf der Registerkarte "Sicherheitseinstellungen" usw. zu aktivieren.

Eine Lösung, die funktioniert, ist die Aktivierung der zweistufigen Authentifizierung von Gmail für den AuthUser, das Generieren eines anwendungsspezifischen Passworts und die Verwendung dieses Passworts als Gmail-Passwort beim Einrichten der Option "E-Mail senden als". Sobald Sie ein App nur Passwort erstellt haben und verwenden Sie es in /etc/ssmtp/ssmtp.conf, beim AuthPass=Sie können die Bestätigung in zwei Schritten deaktivieren, ohne die Bestätigung in zwei Schritten zu widerrufen.


1
2017-08-31 15:34





Haben Sie den angegebenen Link befolgt und die Anweisungen gelesen? So beheben Sie es.

Ich wette, Sie haben den falschen Benutzernamen oder das falsche Passwort eingegeben.

Wenn sie wirklich korrekt sind, vergewissern Sie sich, dass Sie denselben Port verwenden. Oben haben Sie 587 angegeben, während Sie unten 25 angegeben haben.

Dann ist es wahrscheinlich nicht OK zu spezifizieren UseTLS und UseSTARTTLS. Verwenden Sie auf Port 587 UseTLS, bei Port 25 UseSTARTTLS.

Am Ende ist Ihr Hostname nicht "Mailserver". Verwenden Sie einen FQDN.


0
2017-10-10 17:36



@ mmailq, Gemäß Ihrer Lösung habe ich den Port no auf 587 sowohl in der conf-Datei als auch in meinem Benutzernamen und Passwort geändert. - Connect
@@ mmailq, was sollte der FQDN sein? Mein Server Hostname ist Mailserver. - Connect
@@ mmailq, nein es funktioniert nicht der gleiche Fehler kommt. - Connect


Ich habe es behoben, indem ich ein neues Google Mail-Konto erstellt habe, nur für das Senden von E-Mails, die Zwei-Phasen-Authentifizierung aktiviert und ein App-Passwort generiert.

Es wirkt wie ein Zauber!


0
2018-03-05 07:46