Frage Mount CIFS-Host ist inaktiv


Ich habe ein Problem mit einem Mount-Punkt, der zuvor konfiguriert wurde. Es zeigt den Ordner, aber das Mount fehlt und hält "?" Werte für Größe, Berechtigungen usw.

Also habe ich versucht, mit cifs und dem gleichen Befehl von früher wieder zu mounten:

mount -t cifs //nas.domain.local/share /mnt/archive

Aber ich bekomme den Fehler:

Host is down.

Wenn ich die Domain oder IP anpinge, bekomme ich eine korrekte Auflösung und ich habe mich auch ohne Probleme mit smbclient verbunden

 ping nas.domain.local
 ping ip
 smbclient //nas.domain.local/share

Ich schaute mich um, konnte aber keine solide Antwort finden. Irgendwelche Gedanken?


58
2017-08-03 17:13


Ursprung


Tun Sie ein nslookup nas.domain.local entspricht es der IP, die Sie gepingt? - tony roth
Ja, die zurückgegebene IP ist korrekt. Ich kann über die IP und die Domain auch auf das Web-Interface des NAS zugreifen. Ich kann auf die Daten auf meinem Laptop zugreifen, indem ich entweder die Domain oder die IP verwende, so scheint es hier ein anderes Problem zu geben - Kevin
Ergänzen Sie die --verbose Wechseln Sie zu Ihrem Mount-Befehl, posten Sie alle Fehler / Ergebnisse, die relevant erscheinen. - Zoredache
Wird der Dienst sogar auf dem Remote-Server ausgeführt? Es ist ein Linux oder Windows Server? Wenn es sich um Linux handelt, überprüfen Sie, ob der Dienst ausgeführt wird. Stellen Sie sicher, dass keine Änderungen an der Firewall vorgenommen wurden ... Wenn es Windows ist ... dann könnten Sie einen Neustart in Betracht ziehen ... - Jay
@Zoredache Hinzufügen -vvv zum noch ausführlicher Information! - Serge Stroobandt


Antworten:


Dies könnte auch aufgrund einer Protokoll-Nichtübereinstimmung sein. Im Jahr 2017 hat Microsoft Windows-Server gepatcht und empfohlen, das SMB1-Protokoll zu deaktivieren.

Von nun an könnte mount.cifs Probleme mit der Protokollaushandlung haben.

Der angezeigte Fehler ist "Host ist ausgefallen.", Aber wenn Sie debuggen mit:

smbclient -L <server_ip> -U <username> -d 256

Sie erhalten den Fehler:

protocol negotiation failed: NT_STATUS_CONNECTION_RESET

Um dies zu umgehen, verwenden Sie mount oder smbclient mit einem angegebenen Protokoll.

Für sbmclient: add -m SMB2 (oder SMB3 für die neuere Version des Protokolls)

smbclient -L <server_ip> -U <username> -m SMB2

oder für mount: hinzufügen Vers = 2.0 (oder vers = 3.0, wenn Sie Version 3 des Protokolls verwenden möchten)

mount -t cifs //<server_ip>/<share> /mnt/<mountpoint> -o vers=2.0

80
2018-04-05 08:30



Mein NAS ist unter Linux, wenn ich Ihre Lösung versuche smbclient -L 192.168.1.47 -U admin -d 256 Alles funktioniert perfekt, aber wenn ich es versuche mount -t cifs -o username=aa,password=bb,uid=olivier //192.168.1.47/partagefichiers/ /mnt/PartageFichiers es sagt weiter mount error(112): Host is down - Olivier Pons
Hast du versucht, ein Protokoll anzugeben, wie ich es in dieser Antwort erkläre? Versuchen Sie, vers = 2.0 oder vers = 3.0 oder vers = 1.0 (abhängig von diesen NAS-Einstellungen) hinzuzufügen: mount -t cifs -o Benutzername = aa, Passwort = bb, uid = olivier, vers = 2.0 //192.168.1.47/ partagefichiers / / mnt / PartageFichiers - Marcin P
Seltsam. Die Manpage sagt das vers=1.0ist der Standardwert, aber ich konnte mein Netzwerklaufwerk nicht zum Laden bringen, bevor ich es explizit übergeben habe vers=1.0. - Hubro
Ist es möglich, das auf der Windows-Seite zu ändern? Ich habe eine Software, die diese Optionen an cifs weiterleitet und die Vers-Option nicht kennt, so dass sie nicht weitergeleitet wird. - Andrew Savinykh


Auf Archlinux musste ich nach einem letzten Paketupdate vers = 1.0 zu meinen Mount-Optionen hinzufügen. Ich verbinde mich mit einer alten centos 5-Box und bis gestern konnte ich mich verbinden, ohne explizit eine Versionsnummer anzugeben.


32
2017-10-06 07:51



Danke, ich hatte das gleiche Problem, aber ich weiß nicht, welches Upgrade das nötig macht. - Ben
Das ist ein wirklich seltsames Problem. Das Gleiche ist mir heute passiert. Ich habe versucht, smbclient und libwbclient herunterzustufen, aber das Problem blieb bestehen. Vielleicht hat sich etwas auf dem Server geändert. Ich denke, es ist auch CentOS, ich hoffe nicht CentOS 5! Danke für die Problemumgehung :) - jPlatte
Ich musste dies tun, damit mein Fedora 26-System auf einen Mount auf meinem Synology NAS DS413j zugreifen konnte. Meine / etc / fstab hat nun ", vers = 1.0" am Ende der Optionszeichenfolge und keine 'Host ist ausgefallen' -Fehlermeldung mehr. - Neek


USB-Stick am Fritz NAS zeigte "Host Down" für Ubuntu 17.10:

Definieren der Version (vers=1.0) gearbeitet - hier ist die vollständige Zeichenfolge:

sudo mount -t cifs -o vers=1.0,_netdev,username=<user>,password=<pwd>,uid=1000,gid=1000  //192.168.178.1/fritz.nas <local mountpoint>

8
2017-12-22 10:16



Alles funktionierte von innen /etc/fstab cifs montieren; nach dem apt upgrade auf meinem Ubuntu 16.04 ist das passiert. Angeben der -o vers=1.0 Hat den Trick gemacht. Vielen Dank - equivalent8


Sorry, wenn dies eine späte Antwort ist (ich weiß, es ist ein alter Thread), aber ich habe gerade entdeckt, dass es einen anderen möglichen Grund gibt, warum mount.cifs sagen würde, dass der Host ausgefallen ist.

Ich habe ein Antivirenprogramm mit einer Firewall und obwohl ich es explizit auf "Windows-Datei-und Druckerfreigabe" zulassen - eine vordefinierte Regel, blockierte es immer noch Verbindungen. Ich habe dies bewiesen, indem ich die Firewall vorübergehend deaktiviert habe. Hoffe, das hilft jemandem, Host ist down, bedeutet vielleicht nicht, dass es nicht auf Pings reagiert, aber es könnte bedeuten, dass es nicht auf Authentifizierungsversuche reagiert.


5
2017-11-28 22:48



Denken Sie daran, die Firewall auf beiden Seiten zu überprüfen: Client und Server (sowie alle Firewalls, die sich möglicherweise dazwischen befinden). In meinem Fall blockierte die Firewall des Clients Verbindungen zum Server. Ich musste hinzufügen iptables Regeln, um ihnen zu erlauben: iptables -A INPUT -s 1.2.3.4/32 -j ACCEPT und iptables -A OUTPUT -d 1.2.3.4/32 -j ACCEPT, woher 1.2.3.4 war die IP-Adresse des Servers. - Antonio Vinicius Menezes Medei
Mein NAS ist unter Linux, daher habe ich immer noch dieses Problem, aber danke für die Freigabe - Olivier Pons


Ich habe denselben Fehler ohne weiteres von einem neuen Samba-Client erhalten, als ich versuchte, eine CIFS-SMB-Netzwerkfreigabe zu mounten:

mount error(112): Host is down

Schließlich stellte sich heraus, dass ich den SMB-Server-Zugriff zuvor nur auf eine begrenzte Anzahl von IP-Adressen beschränkt hatte, indem ich ihn konfigurierte /etc/samba/smb.conf:

# Allow these IP Addresses to connect: 
hosts allow = 127.0.0.1 127.0.1.13 127.0.1.63

# Anything else not allowed is, by default, rejected
hosts deny = ALL

Das Hinzufügen der festen IP-Adresse des neuen SMB-Clients löste das Problem in diesem speziellen Fall.

Natürlich gibt es eine Vielzahl von anderen Gründen, warum man den oben erwähnten Fehler erhalten kann.


4
2018-04-23 21:47





Ähnliches Problem nach dem Upgrade auf Ubuntu 17.10 mit einer alten Buffalo Diskstation. Gelöst durch hinzufügen von / etc / fstab die Option "vers = 1.0":

// myWDhostname / partage / media / Teil cifs guest, vers = 1.0 0 0


2
2018-03-04 14:12



Jeder, der Ubuntu 18.04 benutzt, fügt das hinzu ,vers=1.0 Option löst das Problem, wenn Sie das Tutorial von verwenden Ji m beim ubuntuhandbook.org/index.php/2014/08/... - Geppettvs D'Constanzo
Ich habe das gleiche Problem und kann es lösen, indem ich Version 1 im Protokoll verwende. Aber ich habe eine sehr geringe Datenübertragungsrate. Ich vermute, dass es an Version 1 liegen könnte, also wäre es besser, eine andere Version zu verwenden. - Ben


Die SMB1-Version des Protokolls wurde nicht weiter unterstützt. Dies ist jedoch die Standardversion, die in älteren Versionen von mount.cifs, z.B. Ich habe dieses Problem mit Version 6.2.

Sie können überprüfen mit: sudo mount.cifs --version

Wenn Sie versuchen, eine Verbindung zu einem SMB3-Server mit SMB1-Protokoll herzustellen, erhalten Sie die Host is down Error.

Die Problemumgehung, die von vielen anderen Antworten hier beschrieben wird, besteht darin, eine andere Version des Protokolls anzugeben. Der folgende Befehl funktioniert für mich: sudo mount -t cifs //server.name.or.ip/shares/Public /target/directory -o username=someuser,domain=somedomain,vers=3.0

jedochWenn der Server, zu dem Sie eine Verbindung herstellen, DFS verwendet, erhalten Sie stattdessen den folgenden Fehler: mount error(38): Function not implemented. Dies liegt daran, dass nur die DFS-Unterstützung für SMB3 verfügbar war in Version 4.11 zum Kernel hinzugefügt.

Sie können Ihre Kernel-Version mit überprüfen uname -a. In meinem Fall war es 3.10 auf CentOS7. ich folgte diese Anweisungen zu aktualisieren und jetzt funktioniert es.


2
2017-09-04 08:43





Gleiches Problem mit der Fritzbox 7490: mount error (112): Host ist ausgefallen

Ich habe -o vers = XX nicht benutzt. So schnell wie ein Hai ich bin, versuchte ich zuerst -o vers = 2.0 und scheiterte.
Sobald ich die Option benutzt habe -o Vers = 1.0, alles funktioniert gut!

Das funktioniert für mich ..

 sudo mount -t cifs -o rw,username=myname_on_the_box,pass\word=mypasswd_on_the_box,vers=1.0 //192.168.1.1/Fritz-nas /media/something/something    

Mein env:
Client: Ubuntu 17.10 Linux 4.13.0-17-generische # 20-Ubuntu SMP x86_64 GNU / Linux
Server: Fritzbox 7490 Firmware 6.83.


1
2017-11-30 11:53



AVM verwendet eine veraltete Version von Samba, die sie selbst pflegen. Das erklärt wahrscheinlich, warum man benutzen muss vers=1.0 anstelle der passenderen neueren Protokollversionen. - 0xC0000022L


Gleiches Problem beim Verbinden mit der Synology DiskStation (DSM 4.3).

Verwenden von vers = 1.0 in den Mount-Optionen funktioniert gut.

Zusätzlich musste ich die Option "noperm" verwenden, da alle Dateien fälschlicherweise vom Eigentümer als nicht lesbar und beschreibbar angezeigt wurden.


1
2017-12-05 10:58





Normalerweise verwende ich diesen Befehlstyp, um eine cifs / smb-Freigabe zu mounten.

mount -t cifs -o rw,netbiosname=nasserver1,credentials=/etc/user_credentials.txt //192.168.1.11/someshare /mnt

Die Anmeldeinformationsdatei sieht folgendermaßen aus:

username=mydomain\user1
password=somepass

Dies kann auch an ein Auto-Setup angepasst werden, so dass das Ein- / Aushängen vom System automatisch über Autofs gehandhabt werden kann.


0
2017-11-04 07:23





In unserem Fall habe ich den Login-Namen des Benutzers (von user2) im AD überprüft. Dort bemerkte ich, dass der Name mit einem Großbuchstaben begann und in Kleinbuchstaben geändert wurde, wie es im Mount-Skript geschrieben ist. Auch wenn wir weder user2 noch das mount-Skript zuvor angefasst haben, war der mount-Befehl plötzlich erfolgreich.

mount --verbose -t cifs //pc/share /my-share -no user=user1,password=pw1 -o uid=user2,gid=group1,dir_mode=0775,file_mode=0664

0
2018-06-29 11:28