Frage Wie behebt man FTP-Fehler "Fehler beim Abrufen der Verzeichnisliste" für das Administratorkonto in IIS 7.5


Unter Verwendung meines Administratorkontos habe ich eine FTP-Verbindung zu meiner IIS 7.5 FTP-Site mit FileZilla hergestellt. Ich konnte eine Datei erfolgreich hochladen, erhalte jedoch weiterhin die Fehlermeldung "Verzeichnisliste konnte nicht abgerufen werden".

Im passiven Modus sind der Befehl, die Antwort und der Fehler:

Command:    LIST
Response:   150 Opening BINARY mode data connection.
Response:   550 The network connection was aborted by the local system. 
Error:  Failed to retrieve directory listing

Im aktiven Modus sind der Befehl, die Antwort und der Fehler:

Command:    PORT 192,168,1,129,102,151
Response:   501 Server cannot accept argument.
Error:  Failed to retrieve directory listing

Was habe ich falsch gemacht?


18
2018-06-10 18:48


Ursprung




Antworten:


Ich hatte dieses Problem ebenfalls und es war mit den Datenports verbunden, die von IIS ausgewählt wurden. Ich habe es eingerichtet, um einen bestimmten Port-Bereich zu verwenden, aber als mein Client versuchte, den passiven Modus zu verwenden, zeigte es, dass er den falschen Port verwendete.

Dieser Beitrag beschreibt die Berechnungsmethode für den verwendeten Port. z.B.

227 Entering Passive Mode (x1,x2,x3,x4,y1,y2)

Die IP, die es verwenden würde, ist x1.x2.x3.x4 und Port (y1 * 256) + y2. Da ich die falschen Werte für y1 und y2 sah, musste ich "Microsoft FTP Service" neu starten, damit er die Werte erkannte, die ich in den FTP-Firewall-Einstellungen in IIS eingestellt hatte.


11
2018-01-21 15:44



Vielen Dank. Neustart des Microsoft FTP-Dienstes löste das Problem für mich. - Shiv
Die IP meines Servers wurde geändert - dies zeigte, dass die alte IP irgendwo benutzt wurde ... Hm - mjohnsonengr
Es war die "Externe IP-Adresse der Firewall" im Abschnitt "Firewall-Unterstützung" - optional nach iis.net/configreference/system.applicationhost/sites/site/... - mjohnsonengr


Klingt nach Firewall-Konfigurationsproblemen. Bitte werfen Sie einen Blick auf diesen Artikel (falls Sie es noch nicht getan haben): http://learn.iis.net/page.aspx/309/configuring-ftp-firewall-settings/


4
2018-06-14 22:47





Für mich hat Neustart nicht geholfen, aber Deaktivieren des passiven Modus hat getan.


3
2017-12-26 02:28



Ich habe explizit den aktiven Modus in FileZilla eingestellt und es hat für mich funktioniert. - Sohail Ahmed


Ich hatte dasselbe Problem, aber ich habe eine Lösung.

Überprüfen Sie Ihr Pfadverzeichnis ftp und fügen Sie einen Benutzer hinzu everyone mit vollem Zugriff für diesen Ordner.


2
2017-07-09 03:21



Ist das nicht ein Sicherheitsrisiko? - Zeeshan


Hier ist eine Lösung von Microsoft.

http://www.iis.net/configreference/system.applicationhost/sites/sitedefaults/ftpserver/directorybrowse

Die Installation der FTP-Erweiterbarkeitsfunktion und das Aktivieren der Liste unter Durchsuchen von Verzeichnissen haben mein Problem gelöst.


2
2017-09-21 13:19





Ich hatte den gleichen Fehler auf Windows 2008 Server und musste alles (Passive Ports) sowohl auf meiner Firewall als auch auf der Windows Firewall (Public Profile) zulassen und musste von IIS 6.0 FTP auf IIS 7.5 FTP aufrüsten.


1
2017-10-18 00:03



Das ist eine sehr drastische Firewall-Lösung für ein bestimmtes Problem. - itsbruce
Ich meine nicht alle Ports, sondern alle passiven FTP-Ports - Alexandre Marcondes


Ran in das gleiche Problem und nach der Einrichtung FTP Firewall Support in IIS, um meine externe IP zu entsprechen, hatte immer noch das Problem. Als letzten Schritt ging ich zum Bearbeiten der eigentlichen FTP-Regel in der Windows Firewall und erlaubt Edge traversal -> Allow Edge Traversal unter dem Advanced Tabulatortreffer Apply/OK und startete die FTPSVC in den Diensten. Danach hatte ich keine Probleme mehr.


1
2017-10-20 14:43