Frage Postfix - Host oder Domäne nicht gefunden


Ich habe gerade Postfix auf meinem ubuntu in einem lokalen Netzwerk installiert.

In diesem Netzwerk habe ich einen Exchange Server (mit der Domäne mail.example.com). Ich hatte ein Problem beim Senden einer E-Mail an eine lokale Adresse: adresse@example.com:

relay=none, delay=0.01, delays=0.01/0/0/0, dsn=4.3.5, status=deferred 
(Host or domain name not found. Name service error for name=example.com
type=AAAA: Host found but no data record of requested type)

Ich habe dieses Problem mit relay_domain in meinem Postfix main.cf gelöst:

relay_domains = example.com
transport_maps = hash:/etc/postfix/transport

Und in meinem / etc / postfix / transport:

example.com smtp:[mail.example.com]

Jetzt kann ich E-Mails auf @ example.com senden und habe einige Majors-Webmails (Gmail, Yahoo, Hotmail ...) getestet. Es klappt.

Aber warum habe ich diesen Fehler bei meinen Adressen "@ example.com"? Wie kann ich sicher sein, dass ich diesen Fehler nie auf einer anderen Domain finde?

Meine Postconf -n geben:

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
inet_interfaces = all
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
mydestination = SRVWEB, localhost.localdomain, localhost
myhostname = SRVWEB
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
myorigin = /etc/mailname
readme_directory = no
recipient_delimiter = +
relay_domains = mutuelle-var.fr
relayhost =
smtp_generic_maps = hash:/etc/postfix/generic
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
transport_maps = hash:/etc/postfix/transport

18
2018-02-20 17:45


Ursprung


Könnten Sie die Ausgabe von postconf -n zur Frage hinzufügen? - ALex_hha
Verwenden Sie IPv6? - ALex_hha
Ich habe postfix config geändert, um jetzt nur ipv4 zu verwenden. Warten wir es ab.. - Vincent LITUR


Antworten:


Ihr Server versucht beim Senden der E-Mail IPv6 zu verwenden. Seit der mail.example.com hat keinen AAAA-record (das ist der gleiche wie ein A-record, aber für IPv6), das funktioniert nicht.

Wenn du Postfix willst noch nie Verwenden Sie IPv6, Sie können dies in der Konfigurationsdatei ändern, wie in der Manpage von postconf (5) erklärt:

When IPv6 support is enabled via the inet_protocols parameter,  Post-
fix will do DNS type AAAA record lookups.

When  both IPv4 and IPv6 support are enabled, the Postfix SMTP client
will attempt to connect via IPv6 before attempting to use IPv4.

Examples:

inet_protocols = ipv4
inet_protocols = all (DEFAULT)
inet_protocols = ipv6
inet_protocols = ipv4, ipv6

Wenn Sie es nur für diese Domain ändern möchten, ändern Sie Ihre Transport-Map zum Lesen

example.com smtp-ipv4:[mail.domain.com]

30
2018-02-21 08:34



Danke für diese Erklärung! Ich habe eine Dokumentation in Französisch gelesen, die besagt, dass ipv4 die DEFAULT-Konfiguration ist. Ich habe jetzt ipv4, und ich habe Postfix neu geladen, scheint zu funktionieren. Danke noch einmal ! - Vincent LITUR
Es hängt davon ab, welche Version von Postfix du verwendest - ich weiß nicht mehr, welche Version standardmäßig ist, aber ich weiß, dass sie es mindestens einmal geändert haben. - Jenny D
Es ist nicht die Verbindung, die fehlschlägt, sondern die DNS-Suche, die ihr vorausgeht. Wenn ich habe inet_protocols = all es versucht nicht A Nachschlagen wenn ein AAAA Nachschlagen schlägt fehl, was sinnlos erscheint. Wenn Sie diesen Wert ändern, müssen Sie Postfix neu starten und nicht nur neu laden. - Synchro


Die einfache Postfix-Konfiguration, die für mich funktioniert hat.

/etc/postfix/main.cf

myhostname = localhost.testing.com
myorigin = testing.com
relayhost =
inet_protocols = ipv4
inet_interfaces = loopback-only
mydestination =

0
2018-03-19 01:49





Die folgende Änderung in /etc/postfix/main.cf löste das Problem für mich.

inet_protocols = ipv6 

Ändern Sie den obigen Wert in

inet_protocols = all

-5
2017-11-12 08:02



Fügt der akzeptierten Antwort nicht viel hinzu und ist, um ehrlich zu sein, nutzlos ohne JennyDs Beitrag, der die Erläuterung. - Deer Hunter