Frage kann nicht zum Mount-Punkt (nfs-server) schreiben und erhält "Permission denied"


Ich versuche zu konfigurieren NFS zwischen zwei RHEL7-Knoten:

erster Knoten:

[root@ip-10-164-175-246 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.0 (Maipo)
[root@ip-10-164-175-246 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.el7.x86_64
[root@ip-10-164-175-246 ~]# cat /etc/exports
/var/www/html/  ip-10-184-161-46.ec2.internal(rw)
[root@ip-10-164-175-246 ~]# 

zweiter Knoten:

[root@ip-10-184-161-46 ~]# mount ip-10-164-175-246.ec2.internal:/var/www/html/ /mnt/
[root@ip-10-184-161-46 ~]# touch /mnt/$$
touch: cannot touch ‘/mnt/3326’: Permission denied
[root@ip-10-184-161-46 ~]# 

Warum kann ich nichts schreiben? /mnt/ über NFS?


19
2017-07-08 16:23


Ursprung


Versuche das zu ändern (rw) im /etc/exports zu (rw,no_root_squash)machen exportfs -av Stellen Sie auf dem Server das Dateisystem erneut auf dem Client bereit und versuchen Sie es erneut. - MadHatter


Antworten:


Wird Ihr Export genutzt? root_squash? Von dem CentOS Dokumente:

root_squash - Verhindert, dass Root-Benutzer, die remote verbunden sind, root haben   Privilegien und weist ihnen die Benutzerkennung für den Benutzer nfsnobody zu. Diese   "quetscht" effektiv die Leistung des Remote-Root-Benutzers auf den niedrigsten   lokaler Benutzer, verhindert unbefugte Änderung von Dateien auf der Fernbedienung   Server. Alternativ deaktiviert die Option no_root_squash root   Quetschen. Um jeden entfernten Benutzer, einschließlich root, zu quetschen, verwenden Sie die   all_squash Option. Um die Benutzer- und Gruppen-IDs anzugeben, die verwendet werden sollen   Remote-Benutzer von einem bestimmten Host, verwenden Sie die Anonuid und Anongid   Optionen jeweils. In diesem Fall kann ein spezielles Benutzerkonto sein   erstellt für Remote-NFS-Benutzer zum Teilen und Angeben   (anonuid =, anongid =), wo ist die   Benutzer-ID-Nummer und ist die Gruppen-ID-Nummer.

Sie müssen die Flagge hinzufügen no_root_squash um dies zu deaktivieren, da es standardmäßig aktiviert ist.


24
2017-07-08 16:40



Danke, alles funktioniert wie erwartet! ich habe gefehlt no_root_squash, Danke noch einmal! - alexus
Ich habe diesen Artikel auf den RHEL-Websites gefunden: access.redhat.com/documentation/de-DE/Red_Hat_Enterprise_Linux/... . Es scheint, dass es überhaupt nicht sicher ist, no_root_squash zu verwenden. Was ist die Lösung, wenn wir ihren Empfehlungen folgen wollen? - Djidiouf
Im Grunde möchten Sie dem Benutzer "nobody" die Möglichkeit geben, die entsprechenden Dateien auf dem NFS-Mount zu ändern. Wenn der Root-Benutzer keinem Benutzer zugeordnet (gequetscht) wird, kann er sie weiterhin ändern. Als Alternative glaube ich, dass NFSv4 Ihnen ermöglicht, korrekte lokale / Server-Kontozuordnungen zu definieren. - Christopher Karel