Frage Installieren von SSL auf einem Windows Server 2012 mit IIS 8.0


Wir sind dabei, eine Website von einem Computer mit Windows Server 2008 R2 / IIS 7.5 auf einen Computer mit Windows Server 2012 / IIS 8.0 zu verschieben, da wir die Vorteile der neuen SNI-Funktion nutzen möchten.

Diese Website verfügt über eine SSL-Verschlüsselung über Go-Daddy. Daher haben wir ihre Website durchsucht, um die SSL-Verschlüsselung für diesen neuen Server erneut zu aktivieren, die entsprechenden Dateien herunterzuladen und die gefundenen Anweisungen zu befolgen Hier für IIS 7.0, da sie für IIS 8.0 nicht verfügbar sind.

Das Problem, das wir haben, ist, dass wenn wir versuchen, "Complete die Zertifikatsanforderung" in IIS, gibt es uns eine Fehlermeldung von "Failed to Remove Certificate"- Wir sind nicht sicher, welches Zertifikat es zu entfernen versucht.

Im Vergleich zu Microsofts Instruktionen gefunden HierWährend des Importvorgangs haben wir festgestellt, dass Sie das Zertifikat in das Verzeichnis "Intermediate Certification Authorities" importieren, das es in den persönlichen Zertifikatsspeicher legt - aber die Anweisungen von Microsoft sagen, das Zertifikat in das neue zu importieren Webhosting-Zertifikatspeicher Nicht sicher, ob dies Teil des Problems sein könnte ...

- AKTUALISIERUNG

Wir dachten, dass es vielleicht etwas mit dem Zertifikat zu tun hatte, das GoDaddy herausgab, also kauften wir ein brandneues Zertifikat für eine andere Website von Thawte - aber wir bekommen immer noch den gleichen Fehler wie "Failed to Remove Certificate".


19
2018-01-07 17:00


Ursprung


Führe den IIS Manager als Administrator aus! - Simon


Antworten:


Ich stieß auf das gleiche Problem mit einem GoDaddy SSL-Zertifikat auf Windows 2012 / IIS 8. Was in meinem Fall funktionierte, nachdem ich die "Fehler beim Entfernen des Zertifikats" Fehler, war das:

  • Ich habe versucht, es noch einmal hinzuzufügen, diesmal ein "Zugriff verweigert" Error.
  • Ich habe auch versucht, es in den "Personal" Store anstelle von "Web Hosting" aber gleich hinzuzufügen "Zugriff verweigert" Fehler ist aufgetreten
  • Also ging ich zurück zum Snap-In Zertifikate mit MMC und fand das Zertifikat schon da - unter Zertifikate (Lokaler Computer) / Persönlich
  • Anstatt das Export / Import-Ding zu machen, das Scott vorgeschlagen hat, habe ich einfach versucht, das Zertifikat herunter zu ziehen Zertifikate (Lokaler Computer) / Webhosting Knoten - und, überraschenderweise, hat es funktioniert
  • Nachdem ich das oben beschriebene getan hatte, ging ich zurück zum IIS Manager und konnte das Zertifikat sofort in den Site Bindings verwenden

21
2018-05-13 09:03



Das hat perfekt funktioniert. Vielen Dank! - Kevin Babcock
Vielen Dank. Ich hätte mir wahrscheinlich stundenlang den Kopf gekratzt, wenn du das nicht gepostet hättest. - diadem
Ich habe diesen Fehler bekommen, als ich versucht habe, dass IIS es in "Web Hosting" hinzufügt - wenn ich es in "Personal" einfügen lasse, ist es in Ordnung. Danach zog ich es in die Web-Hosting-Kategorie und alles war gut. Ich habe keine Idee warum. - jocull


Ich stieß auf eine ähnliche Ausgabe. Ich musste das Zertifikat als .P7B-Datei herunterladen, das Zertifikat im lokalen Cert Store installieren und dann das Zertifikat als .PFX mit einem Passwort exportieren.

Klicken Sie mit der rechten Maustaste auf das Zertifikat und klicken Sie auf "Installieren". Sie können "Automatisch" oder "Der folgende Speicher" auswählen. Ich glaube, Automatic installiert es in "Lokaler Computer / Persönlich". Also in MMC, laden Sie das Zertifikat Snap-in für den lokalen Computer, und dann in den persönlichen Ordner suchen oder wo Sie es zu installieren, sollten Sie Ihre Cert sehen. Rechtsklick, Alle Aufgaben, Exportieren

Sobald ich das .PFX-Zertifikat hatte, konnte ich dieses Zertifikat in IIS8 importieren und es in den SSL-Bindungen für die Site verwenden.

Scott <-


4
2018-02-16 17:06



Hatte das gleiche Problem und das scheint auch für mich funktioniert zu haben. - Multiverse IT
was ist der "lokale cert store"? - lrkwz
Ich habe oben einige Details hinzugefügt. - scooter133
Ich habe den PFX von IIS auf einen anderen Server exportiert. War in der Lage, es in der Win2012 IIS 8.5-Box zu importieren. - mobill


Ich hatte das gleiche Problem. Ich habe mit openssl behoben

openssl pkcs12 -export -in my.crt -inkey my.key -certfile my.bundle -out my.pfx

Als ich nach IIS 8.5 importiert habe


2
2018-03-21 18:01





Führen Sie den IIS-Manager als Administrator aus! Immer - wenn SSL geändert wird!

Auch wenn GoDaddy ein Zertifikat automatisch aktualisiert, verwendet es den gleichen Schlüssel, den Sie ursprünglich hatten - Sie müssen also nicht für dasselbe Gerät erneut Schlüssel eingeben. Es ist das Fehlen von laufen als Admin, die diese dummen Nachrichten gibt. Ich vergesse immer. Alle zwei Jahre.

Um zu erneuern, wenn Godaddy Ihr Zertifikat erneuert, ohne dass Sie eine neue CSR bereitstellen:

  • Führen Sie den IIS-Manager als Administrator aus
  • Gehe zu Server Certificates
  • Klicken Sie mit der rechten Maustaste und wählen Sie Renew
  • Wählen Sie die dritte Option: Complete certificate renewal request
  • Wähle aus .crt Datei

1
2018-02-06 21:36





Ich habe versucht, meine erneute Lizenz hinzuzufügen und hatte dasselbe Problem. Ich habe herausgefunden, dass mein vorheriges SSL-Zertifikat aktiv war und von einer meiner Domains genutzt wurde. Ich entfernte die vorherige und fügte die neue hinzu und das Problem wurde gelöst.


0
2018-04-20 01:45





Ich hatte die gleiche Reihe von Fehlern und Problemen, sah sich mmc Snapin für Zertifikate ... cert scheint da zu sein (ohne dass ich etwas zu tun, um die Fehler zu beheben)

Versucht es in IIS .... scheint zu arbeiten .... Aktuelle Schlussfolgerung: Die Fehler sind falsch.


0
2018-05-31 23:25