Frage Wie deaktiviere ich den Piepton im Terminal unter Linux? [geschlossen]


Ich benutze seit kurzem einen neuen Desktop-PC mit Ubuntu Linux. Das Endgerät piepst jedoch ärgerlich. Wenn ich am Anfang der Zeile bin und die Rücktaste drücke, piept es, um zu sagen, dass keine Zeichen zu löschen sind. Wenn ich versuche, den Tab abzuschließen, und es keine Vervollständigungen dafür gibt, piept es.

Wie schalte ich das aus?


19
2018-06-16 09:13


Ursprung


askubuntu.com/q/275760/4066 - Nicolas Raoul


Antworten:


Da der PC-Lautsprecher insgesamt nervig ist (zumindest denke ich es), gehe ich einfach

modprobe -r pcspkr

und füge es zu /etc/modprobe.d/blacklist.conf wie folgt hinzu:

blacklist pcspkr

Keine Signaltöne mehr. Je.

Funktioniert natürlich nicht für Glocken durch / dev / snd / *


17
2018-06-16 09:34



Neuere Kernel verwenden stattdessen snd_pcsp, wenn das obige nicht funktioniert. Versuchen Sie, modprobe -r snd_pcsp und blacklist snd_pcsp. - Joseph Kern
Wirf das Baby mit dem Bade aus! - Dan Carley
Ich denke, "das Baby mit dem Badewasser hinauswerfen" würde den PC-Sprecher trennen ;-) - Kyle Brandt♦
+1 Das beantwortete meine entgegengesetzte Frage: "Wie bekomme ich Terminal-Signaltöne zur Arbeit?" - Ternary
Das ist nicht so eine Antwort, ich möchte nur das Terminal piepen! Nicht mein Sound, um wegzugehen! - gideon


Einfachste Lösung: setzen

set prefer-visible-bell on

in deiner ~/.inputrc.

Dies funktioniert jedoch nur für Anwendungen, die die readline-Bibliothek verwenden (einschließlich Bash). Andere Anwendungen können sich immer noch dafür entscheiden, bei Ihnen zu piepsen.

Wenn Sie alle Signaltöne deaktivieren möchten, müssen Sie dies im Terminal tun. Wie das geht, hängt von Ihrem Terminal ab. Im xterm es ist Option -vb (funktioniert auch in vielen anderen Terminals, beispielsweise in rxvt). Die meisten grafischen Terminals haben eine Konfigurationsoption dafür.

Siehe auch die Sichtbare Glocke Mini-Howto für alle schmutzigen Details.


16
2018-06-16 09:20





von Cybercity:

  • Gnome-Terminal öffnen
  • Klicken Sie auf Einstellungen> Einstellungen> Silence Terminal Bell

7
2018-06-16 09:19



Diese klingen wie die Anweisungen für eine KDE-Anwendung und funktionieren nicht genau auf Gnome Terminal. Wie auch immer, Sie waren auf dem richtigen Weg. - Rory


In Ergänzung zu setterm und GNOME-Einstellungen Lösungen, die bereits dort vorgeschlagen werden, sind die folgenden:

Wenn Sie X ausführen, öffnen Sie ein xterm und gib ein xset b off.

So deaktivieren Sie die Systemglocke bei der Bash-Startbearbeitung ~/.inputrc oder /etc/inputrc und füge die Zeile hinzu set bell-style none oder set bell-style visual wenn Sie einen Bildschirm blinken möchten.

Es gibt einen guten Artikel dazu Hier.


7
2018-06-16 09:24





$ setterm -blength 0

Sie möchten das zu Ihrem Bash-Profil hinzufügen.


6
2018-06-16 09:18