Frage Nach Windows 7 SP1 IIS-Fehler mit "ungültiger Anwendungspfad"


Ich erhalte diese neue, seltsame Fehlermeldung in IIS nach der Aktualisierung von Windows 7 (x64) mit SP1.

  1. Öffnen Sie den IIS-Manager
  2. Zu einer vorhandenen virtuellen Anwendung navigieren (oder eine neue erstellen)
  3. Öffne es Grundeinstellungen Dialog
  4. Klicken Einstellungen testen
  5. Die Fehlermeldung wird angezeigt

Es passiert mit neuen Anwendungen und auch mit solchen, die bereits vorher (und ohne dieses Problem) vorhanden waren.

Die Anwendungen selbst funktionieren weiterhin.

Hat jemand das schon herausgefunden?


20
2018-03-10 14:13


Ursprung


In welchem ​​Pfad ist Ihr Website-Root festgelegt? * Existiert der Pfad? * Hat Ihr IIS-Benutzer Zugriff auf den Pfad? * Fügen Sie dem Pfad eine einfache GIF-Datei hinzu. Kannst du darauf zugreifen? * Wenn erfolgreich, versuchen Sie eine ASP.NET-Seite. Funktioniert es? - erikbra
@Erik, es gibt keine Probleme, die Website im Browser zu öffnen, die Seiten der Bilder zu sehen. Das Problem, nach dem ich frage, ist im IIS Manager.
Aber was sagt die Fehlermeldung? Sind Sie sicher, dass Sie die integrierte Sicherheit nicht verwenden und der IIS-Manager dies nicht testen kann, da Sie bei der Ausführung des IIS-Managers nicht authentifiziert sind? - erikbra


Antworten:


Überprüfen Sie, ob Ihre spezifische Version von ASP.NET wie folgt in IIS zulässig ist:

  1. Wählen Sie den obersten Server im IIS-Manager aus.
  2. Doppelklicken Sie auf ISAPI und CGI-Einschränkungen.
  3. Wenn Ihre Version von ASP.NET nicht zulässig ist, klicken Sie mit der rechten Maustaste und Zulassen.

Das hat es für mich gelöst, hoffe es funktioniert auch für dich.


4
2018-06-10 20:52



Vielen Dank. Viele Fragen ergeben sich daraus. Ich frage mich, warum sie das zum Standard machen. Warum ist das nicht die erste Antwort, wenn Sie diesen Fehler nachschlagen? Die Liste geht weiter. - Brad Bruce


Ich hatte das gleiche Problem, indem ich explizite Berechtigungen für IIS_IUSRS in dem Ordner gab, in dem sich meine Anwendung befindet.


1
2018-03-14 12:20



Welche ausdrückliche Erlaubnis hast du gegeben? Ich habe versucht, es Vollzugriff zu geben und es hat nicht geholfen. Nur um klar zu sein, hatte ich alle richtigen Berechtigungen vor Win7-SP1. Ein Klick auf Einstellungen testen funktionierte früher gut.
Nur gelesen, nichts Schickes ...


Ich hatte dasselbe Problem, hier ist meine Lösung.

  1. Überprüfen Sie den Anwendungspool, den Ihre Anwendung verwendet.
  2. Klicken Sie auf Anwendungspool und klicken Sie auf Erweiterte Einstellungen, um zu einem neuen Fenster zu gelangen.
  3. Überprüfen Sie die .NET Framework-Version
  4. Legen Sie Benutzerprofil laden auf True fest
  5. Setzen Sie ping auf True

1
2017-07-13 19:21





Etwas, das für mich funktionierte, war das Zulassen von 32-Bit-Anwendungen im Anwendungspool.

Es scheint, dass die Anwendung, die ich lief, eine 32bit war

HTH


1
2018-02-06 10:04





Ich habe immer noch keine Lösung gefunden, aber finde einen Workaround.

Sie können die IIS-Konfiguration manuell in system32 \ intsrv \ config \ applicationHost.config ändern. Manuelles Erstellen (Kopieren und Einfügen) des Abschnitts in und.


0
2018-05-25 13:25



Ihre Antwort scheint Informationen zu fehlen. Vielleicht möchten Sie das beheben oder entfernen Sie es, wenn Sie nicht abgelehnt werden möchten. - Remi Despres-Smyth


Innerhalb von IIS in den "Erweiterten Einstellungen" der Anwendungspools, unter "Allgemein" gibt es eine "Enable 32-Bit Applications" -Einstellung. Als ich das auf True stellte, ging dieser Fehler für mich weg.


0
2018-03-24 16:02



Das hatte ich schon probiert. Versuchte nochmal. Machte keinen Unterschied.


IMHO ... Dieser Test ist von geringem Wert, es sei denn, Sie möchten einen bestimmten Benutzer testen und auch dann ist es marginal ... Benutzerkonten zu Ordnern hinzuzufügen, damit dieser Test (wie andere angegeben) Ihre Sicherheit marginalisiert ... besser Diesen Test nicht durchführen, um Benutzer zu Ordnern hinzuzufügen und Ihre Sicherheit in irgendeiner Form oder Form zu gefährden ...

Solange Ihre Seite funktioniert ... sollte das Ihr Maßstab sein ...


0
2018-04-03 20:11