Frage IBus> = 1.5.11 auf Ubuntu


Ich benutze Ubuntu 15.04. Ich habe die neueste Version von IBus installiert, also zeigt der Befehl:

apt-get changelog ibus

Aber die Software, die ich benutze (PHPStorm 10) gibt eine Warnung, dass IBus mit einer Version von mindestens 1.5.11 empfohlen wird. Wie kann ich es installieren?


20
2017-11-10 10:05


Ursprung


Sie haben die Version, die mit Ubuntu 15.04 geliefert wurde, nicht die neueste Version, siehe: packages.ubuntu.com/search?keywords=ibus - ptman


Antworten:


Installiert jetzt diese Builds https://launchpad.net/~tista/+archive/ubuntu/wayland/+build/8264511

Laden Sie die folgenden Dateien in einen Ordner herunter

gir1.2-ibus-1.0_1.5.11+git20151104-2-0ubuntu1~xenial1_amd64.deb
ibus_1.5.11+git20151104-2-0ubuntu1~xenial1_amd64.deb
ibus-gtk_1.5.11+git20151104-2-0ubuntu1~xenial1_amd64.deb
ibus-gtk3_1.5.11+git20151104-2-0ubuntu1~xenial1_amd64.deb
libibus-1.0-5_1.5.11+git20151104-2-0ubuntu1~xenial1_amd64.deb

Installieren

sudo dpkg -i *.deb

Nicht auf die Warnungen achten und neu starten


20
2017-11-10 21:55



das war sehr nützlich für mich! danke +1. - 1111161171159459134
Die Installation verlief reibungslos für mich. Kann noch nicht sagen, ob der ärgerliche Bug mit der plötzlich in PHPSstorm laufenden Tastatur vorbei ist ... Aber wenn das nicht funktioniert oder für diejenigen, die ibus nicht upgraden können, hat die Deinstallation von ibus das Problem für mich in der Vergangenheit komplett behoben , ohne viel negative Nebenwirkungen (trotz nicht-US-Tastatur). - rixo
Vielen Dank. Funktioniert auch auf Ubuntu 15.10. Ich habe bisher keine negative Nebenwirkung bemerkt. - DanielaWaranie
Ich tat das dpkg aber die Installation scheint in Ubuntu 14.04 LTS gescheitert zu sein: Errors were encountered while processing: gir1.2-ibus-1.0:amd64 ibus  obwohl ibus version zeigt an IBus 1.5.11 jetzt. - Vadorequest
One-Liner für die Faulen:  mkdir -p /tmp/ibus && cd /tmp/ibus && curl -O http://launchpadlibrarian.net/234615974/gir1.2-ibus-1.0_1.5.11-1ubuntu2_amd64.deb -O http://launchpadlibrarian.net/234615976/ibus-gtk_1.5.11-1ubuntu2_amd64.deb -O http://launchpadlibrarian.net/234615975/ibus-gtk3_1.5.11-1ubuntu2_amd64.deb -O http://launchpadlibrarian.net/234615978/ibus_1.5.11-1ubuntu2_amd64.deb -O http://launchpadlibrarian.net/234615979/libibus-1.0-5_1.5.11-1ubuntu2_amd64.deb && sudo dpkg -i *.deb - Flatron


Aufgrund einiger der Kommentare habe ich beschlossen, ibus 1.5.12 zu installieren. Ich benutze Ubuntu 14.04, und basierend auf der Antwort von @Fabio funktionierte das für mich hier: https://launchpad.net/~tista/+archive/ubuntu/wayland/+build/8927526

gir1.2-ibus-1.0_1.5.12+git20160201-0ubuntu1-xenial1_amd64.deb
ibus_1.5.12+git20160201-0ubuntu1-xenial1_amd64.deb
ibus-gtk3_1.5.12+git20160201-0ubuntu1-xenial1_amd64.deb
ibus-gtk_1.5.12+git20160201-0ubuntu1-xenial1_amd64.deb
libibus-1.0-5_1.5.12+git20160201-0ubuntu1-xenial1_amd64.deb

EDIT - Fehler mit dpkg
Fehler beim Entpacken hängen wahrscheinlich mit nicht erfüllten Abhängigkeiten zusammen.
Herunterladen von Ubuntu-Pakete die fehlenden Pakete.
Paketieren Sie manuell, bis die Abhängigkeiten erfüllt sind.
Versuchen Sie dann, die oben genannten Pakete erneut zu entpacken.


4
2018-02-04 12:53





Nach dem Herunterladen der Pakete von https://launchpad.net/~tista/+archive/ubuntu/wayland/+build/8927526  und dann rennen dpkg -i *.deb Führen Sie die heruntergeladenen Pakete aus

apt-get install -f 

um die Fehler zu beheben, die während der Installation von dpkg aufgetreten sind (einige Abhängigkeiten fehlen).

Kann bestätigen, dass es unter Ubuntu 15.10 funktioniert


1
2018-03-07 08:33



Das ist sehr hilfreich. Vielen Dank! - MY_G


Ich bin auf Ubuntu 14.04.5 und stieß auf das gleiche Problem mit Android Studio. Ich bevorzuge es, ibus wenn möglich zu aktualisieren. Es stellte sich heraus, es war sehr einfach ^^.

  1. Aktualisieren sources.list mit diesen zwei Zeilen:

    deb http://ca.archive.ubuntu.com/ubuntu/ xenial main restricted
    deb-src http://ca.archive.ubuntu.com/ubuntu/ xenial main restricted
    
  2. Update ibus:

    sudo apt-get update
    sudo apt-get install ibus
    
  3. Entfernen Sie die hinzugefügten Zeilen aus sources.list.

Vor dem Aktualisieren sources.list:

sudo apt-cache policy ibus
ibus:  
  Installed: 1.5.5-1ubuntu3.2  
  Candidate: 1.5.5-1ubuntu3.2  
  Version table:  
  *** 1.5.5-1ubuntu3.2 0  
        500 http://ca.archive.ubuntu.com/ubuntu/ trusty-updates/main 
amd64 Packages
        100 /var/lib/dpkg/status
     1.5.5-1ubuntu3 0
        500 http://ca.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Nach dem Aktualisieren von ibus:

sudo apt-cache policy ibus
ibus:
  Installed: 1.5.11-1ubuntu2
  Candidate: 1.5.11-1ubuntu2
  Version table:
 *** 1.5.11-1ubuntu2 0
        500 http://ca.archive.ubuntu.com/ubuntu/ xenial/main amd64 Packages
        100 /var/lib/dpkg/status
     1.5.5-1ubuntu3.2 0
        500 http://ca.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
     1.5.5-1ubuntu3 0
        500 http://ca.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

^^ Zu einfach. Ich bin misstrauisch, dass bald etwas explodieren wird.


1
2017-11-07 18:38