Frage apt-get update erhält 404 auf debian lenny


Hier ist mein /etc/apt/sources.list

###### Debian Main Repos
deb http://ftp.us.debian.org/debian/ lenny main contrib non-free

###### Debian Update Repos
deb http://security.debian.org/ lenny/updates main contrib non-free
deb http://ftp.us.debian.org/debian/ lenny-proposed-updates main contrib non-free

Wenn ich es tue:

# apt-get update

Ich bekomme ein paar gute Zeilen, dann:

Err http://ftp.us.debian.org lenny/contrib Packages
  404 Not Found [IP: 35.9.37.225 80]
Err http://ftp.us.debian.org lenny/non-free Packages
  404 Not Found [IP: 35.9.37.225 80]
Err http://ftp.us.debian.org lenny-proposed-updates/main Packages
  404 Not Found [IP: 35.9.37.225 80]
Err http://ftp.us.debian.org lenny-proposed-updates/contrib Packages
  404 Not Found [IP: 35.9.37.225 80]
Err http://ftp.us.debian.org lenny-proposed-updates/non-free Packages
  404 Not Found [IP: 35.9.37.225 80]
Err http://ftp.us.debian.org lenny/main Packages
  404 Not Found [IP: 35.9.37.225 80]
W: Failed to fetch http://security.debian.org/dists/lenny/updates/main/binary-i386/Packages  404 Not Found [IP: 149.20.20.6 80]    
W: Failed to fetch http://security.debian.org/dists/lenny/updates/contrib/binary-i386/Packages  404 Not Found [IP: 149.20.20.6 80]    
W: Failed to fetch http://security.debian.org/dists/lenny/updates/non-free/binary-i386/Packages  404 Not Found [IP: 149.20.20.6 80]    
W: Failed to fetch http://ftp.us.debian.org/debian/dists/lenny/contrib/binary-i386/Packages  404 Not Found [IP: 35.9.37.225 80]    
W: Failed to fetch http://ftp.us.debian.org/debian/dists/lenny/non-free/binary-i386/Packages  404 Not Found [IP: 35.9.37.225 80]    
W: Failed to fetch http://ftp.us.debian.org/debian/dists/lenny-proposed-updates/main/binary-i386/Packages  404 Not Found [IP: 35.9.37.225 80]    
W: Failed to fetch http://ftp.us.debian.org/debian/dists/lenny-proposed-updates/contrib/binary-i386/Packages  404 Not Found [IP: 35.9.37.225 80]    
W: Failed to fetch http://ftp.us.debian.org/debian/dists/lenny-proposed-updates/non-free/binary-i386/Packages  404 Not Found [IP: 35.9.37.225 80]    
W: Failed to fetch http://ftp.us.debian.org/debian/dists/lenny/main/binary-i386/Packages  404 Not Found [IP: 35.9.37.225 80]    
E: Some index files failed to download, they have been ignored, or old ones used instead.

22
2018-03-29 01:53


Ursprung




Antworten:


Von ein wenig Herumstöbern scheint es ein Problem mit den Debian-Spiegeln zu sein. Laut der Spiegelinfo sollte Lenny verfügbar sein, obwohl Sie möglicherweise jede Instanz von 'Lenny' mit 'Oldstable' in ändern müssen /etc/apt/sources.list. Das Aufziehen von 3 Spiegeln hat jedoch gezeigt, dass "Lenny" und "Oldstable" nicht mehr aufgeführt sind.

Aktualisieren: Ich stocherte ein bisschen mehr herum und fand, dass die USC Spiegel sieht aus, dass 'lenny' noch aufgelistet ist. Kommentieren Sie Ihre bestehenden Einträge in sources.list und duplizieren sie die:

deb http://ftp.us.debian.org/debian/

Ersetzt mit:

deb ftp://mirrors.usc.edu/pub/linux/distributions/debian/

Sehen Sie, ob das den Trick macht.

Mit etwas Glück ist das ein vorübergehendes Problem und wird sich in ein paar Tagen lösen.

Update 2: Es sieht so aus, als wäre das nicht vorübergehend, und http://archive.debian.org ist der beste Ort, um Pakete für Lenny zu ziehen. Es sieht auch so aus, als ob der Sicherheits-Support für Lenny am 12. Februar 2012 beendet wurde, obwohl sie am 10. März 2012 das Point Update 5.0.10 veröffentlicht haben.

Es würde sich wahrscheinlich lohnen, ein Upgrade zu planen, insbesondere für alle Internet / Public-Server.


14
2018-03-29 02:19



Vielen Dank! Was ist mit "security.debian.org"? - JoelFan
Ich habe auch gefunden serverfault.com/questions/373314/ ... - JoelFan
Guter Fang. Ich werde meine Antwort mit ein paar Details davon aktualisieren, für den Fall, dass jemand hier reinkommt. - Christopher Cashell
Warum sagst du, es ist vorübergehend? Es scheint, als wäre es EOL. - JoelFan
Ich würde es nicht als "Problem mit den Spiegeln" bezeichnen, dass sie aufgehört haben, eine Version zu tragen, die nicht mehr unterstützt wird. - Wyzard


modifiziere deine /etc/apt/sources.list wie folgt:

deb http://archive.debian.org/debian/ lenny main contrib non-free
deb-src http://archive.debian.org/debian/ lenny main contrib non-free

deb http://archive.debian.org/debian-security lenny/updates main contrib non-free
deb-src http://archive.debian.org/debian-security lenny/updates main contrib non-free

deb http://archive.debian.org/debian-volatile lenny/volatile main contrib non-free
deb-src http://archive.debian.org/debian-volatile lenny/volatile main contrib non-free

28
2018-03-29 09:48





Lenny-Pakete wurden von allen Spiegeln entfernt auf: archive.debian.org   Also update deine sources.list zu:   Deb http://archive.debian.org Lenny Hauptbeitrag

OK - das würde nicht für mich funktionieren, aber

 deb http://archive.debian.org/debian lenny main contrib

hat getan


2
2018-03-29 09:50