Frage Installiere Xvfb über das yum - yum - Repository für Xvfb?


Ich versuche Xvfb auf einem RHEL 6.2 System mit yum zu installieren. Alle Hilfe, die ich gefunden habe, sagt jedoch:

    yum install Xvfb

oder...

    yum install xorg-x11-server-Xvfb

Das würde sicher funktionieren, wenn ich das richtige Repo konfiguriert hätte, was ich nicht weiß. Weil ich den Fehler bekomme:

    No package Xvfb available.

Die einzigen Repos, die ich auf diesem System habe, sind redhat.repo und rhel-source.repo. Welcher Repo enthält das Xvfb-Paket?

Vielen Dank!


23
2017-12-28 19:54


Ursprung




Antworten:


Umm, das Paket heißt "xorg-x11-server-Xvfb" auf CentOS5.

Sie sollten also die zweite Option "yum xorg-x11-server-Xvfb installieren" verwenden. Sie können "yum search xvfb" ausführen, was Ihnen auch den richtigen Namen des Pakets gibt.


31
2017-12-28 20:07



Versuchte beide, beide arbeiten nicht. Die Suche gibt keine passenden Pakete zurück, und "yum install xorg-x11-server-Xvfb" sagt mir "Kein Paket xorg-x11-server-Xvfb verfügbar". - AWT
xorg-x11-server-Xvfb.i386 auf meiner RHEL 5.5-Maschine .. Frage mich, ob sie es in 6.0 gestrichen haben - Tim
Seltsam. Es ist ein Standard-RHEL-Paket. Vielleicht "yum clean" ausführen, um lokale Daten zu löschen? Das könnte etwas sein, mit dem Sie RH überfragen. - cjc
@Tim. Auf CentOS6.2 sehe ich "xorg-x11-server-Xvfb.i686 0: 1.10.4-6.el6_2.1", so dass es von Standard-RHEL-Quellen abgeleitet ist. Es wird auch auf diesem offiziellen RH Dokument erwähnt: rhn.redhat.com/errata/RHBA-2011-1816.html also sollte es bei RedHat verfügbar sein. Das klingt eher nach einem Problem mit Torgis Yum-Konfiguration. - cjc
Könnte sehr gut sein. Ich habe versucht, alles sauber zu machen, yum alle xvfb suchen und nichts bekommen. Welche Repos haben Sie in /etc/yum.repos.d hinzugefügt? Ich habe mir nur mein Redhat Repo angeschaut und es ist leer. Das ist wahrscheinlich nicht gut. - AWT


Aktivieren Sie die optionalen Inhaltsrepositorys, indem Sie /etc/yum.repos.d/redhat-rhui.repo bearbeiten.

Öffnen Sie die Dateisuche nach optional - Änderung aktiviert = 0 bis aktiviert = 1

[rhui-REGION-rhel-server-optional]
name=Red Hat Enterprise Linux Server 7 Optional (RPMs)
mirrorlist=https://rhui2-cds01.REGION.aws.ce.redhat.com/pulp/mirror/content/dist/rhel/rhui/server/7/$releasever/$basearch/optional/os

enabled=1

Das sollte funktionieren.


6
2017-09-17 23:25



ich benutzte sudo yum install --enablerepo rhel-7-server-optional-rpms xorg-x11-server-Xvfb. Nur ein anderer Weg, um das zu erreichen, was @Aamreeta hier vorschlägt (ohne die Datei yum.repos.d / redhat.repo zu editieren). - Juan


Es ist auf den optionalen Kanälen Client, Workstation und Server in RHN verfügbar: (Beachten Sie, dass die URLs hier zur Eingabe Ihres redhat support-Kontos auffordern)

https://rhn.redhat.com/network/software/packages/name_overview.pxt?package_name=xorg-x11-server-Xvfb&archIdList=&archLabelList=&search_subscribed_channels=yes

Sie müssen natürlich die entsprechende Berechtigung konfigurieren, um einen dieser Kanäle mit Ihrem System zu nutzen.

Sie können Pakete unter der folgenden URL suchen, wenn Sie die Package Kit-GUI oder die entsprechende Yum-Funktionalität nicht kennen (oder nicht mögen):

https://rhn.redhat.com/rhn/channels/software/Search.do

Prost!


4
2017-12-31 11:49



Dumme Frage als Follow-up ... Sobald ich einen Support-Account habe, wo stelle ich diese Informationen auf mein System, damit diese Yum-Repositories funktionieren? - AWT
Ihr Link gibt mir alles ... Ich glaube, dass es nicht mehr funktioniert .. - caarlos0


Danke für die Erklärung der Lösung ... Aus irgendeinem Grund war der FTP-Link für mich fehlerhaft und so bekam ich Fehler wie ...

ftp://ftp.redhat.com/pub/redhat/rhel/beta/6Server/x86_64/os/repodata/repomd.xml:[Errno 14] PYCURL ERROR 9 - "Server denied you to change to the given directory"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rhel-beta. Please verify its path and try again

Beachten Sie den "6Server" -Teil, dieses Verzeichnis existiert nicht oder etwas stimmt nicht mit dem, was ich gemacht habe.

Wie auch immer, am Ende habe ich $ Releasever ersetzt durch "6" ftp://ftp.redhat.com/pub/redhat/rhel/beta/6/x86_64/os/repodata/repomd.xml

und von dem, was ich sagen kann "sudo yum xorg-x11-server-Xvfb installieren" installieren Sie es gut


1
2018-02-17 19:31





Ok, ich habe es herausgefunden. Die Antwort ist, das Rhel-Beta-Repository hinzuzufügen und damit die Notwendigkeit eines RHN-Abonnements zu umgehen:

[rhel-beta]
name=Red Hat Enterprise Linux $releasever Beta - $basearch
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/$basearch/os/
enabled=1
gpgcheck=0
#gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2
priority=1
exclude=*release

[rhel-beta-optional]
name=Red Hat Enterprise Linux $releasever Beta (Optional) - $basearch
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/optional/$basearch/os/
enabled=1
gpgcheck=0
#gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2
priority=1
exclude=*release

Lief wie am Schnürchen.


-1
2018-01-03 16:53



Wo sollst du diese Konfiguration hinstellen? - slashdottir
Es hat nicht funktioniert. - Robert