Frage IIS / SMTP - Emails stecken in Mailroot / Queue


Ich versuche, E-Mails über SMTP im IIS-Pickup-Verzeichnis zu senden. Leider gehen die E-Mails einfach in den Ordner mailroot / queue und bleiben dort. Sie werden nie wirklich gesendet.

Weiß jemand, warum das passieren würde und eine mögliche Lösung für das Problem?


25
2018-01-14 22:36


Ursprung


Ich hatte das gleiche Problem, aber es stellte sich heraus, dass dies nur für eine bestimmte Zieldomäne / Server passierte, d. H. Ich mailte mir / Kollegen Arbeitsadressen (Exchange-Server) und die Mail saß nur in der Warteschlange. Ich habe versehentlich eine Nachricht an mein persönliches Google Mail-Konto gesendet und ohne Problem gesendet. Anschließend getestet mit Hotmail und einem anderen Exchange-Server als Ziel und Mail geschickt. Aber um herauszufinden, was das Problem ist, aber wenn jemand immer noch ein ähnliches Problem hat, könnte es sein, dies zu überprüfen! - Matthew Swain
@ MatthewSwain Ich sehe das gleiche hier. Hunderte, wenn nicht Tausende von Mails wurden erfolgreich versandt, aber 53 Mails sind derzeit in der Warteschlange. Sie scheinen alle für bestimmte Empfänger / Domänen zu sein. - Zero3


Antworten:


Hatte ein ähnliches Problem mit Dateien in der Warteschlange stecken. Im IIS-Manager, Virtueller SMTP-Server> Eigenschaften> Bereitstellung> Ausgehende Verbindungen. Die Option für Limit number of connections to wurde überprüft und der Wert war 0. Daher wurde es so konfiguriert, dass keine ausgehenden Verbindungen hergestellt werden, sodass die E-Mails den Server nie verlassen. Ich habe die Option deaktiviert und den SMTP-Server neu gestartet und alles war gut.


18
2017-11-06 17:31



Guter Fang von diesem .. aber ich kann mich nicht erinnern, überhaupt in dieses Fenster gegangen zu sein, um diese Option zu überprüfen .. nicht sicher, wie es mit einer 0 an erster Stelle endete !! - krilovich
Dies ist für uns heute eingetreten. Ich ging hinein, um eine Einstellung zu ändern, und "Anzahl der Verbindungen beschränken auf" auf der Registerkarte "Allgemein" wurde überprüft und hat auch "0". Offensichtlich hat dies auch die Einstellung "Outbound Connections" geändert. - Travis


Ich hatte dieses Problem heute.

Nach dem Neustart des Dienstes "SMTP (Simple Mail Transfer Protocol)" wurde die Arbeit wieder aufgenommen.


7
2017-10-18 16:33





Nur zur Erinnerung: Wir hatten einen Fall, in dem der Server die Namen aufgrund von fehlerhaften DNS-Einstellungen nicht mehr auflösen konnte. Das resultierende Verhalten war genau das, das Sie beschrieben haben.


3
2017-10-25 16:29



Was war das DNS-Problem? - Shaamaan
In meinem Fall musste ich unsere Domänencontroller neu starten. Aus welchem ​​Grund auch immer, E-Mails an einen bestimmten Kunden kamen nicht durch. Wir hosten eine Box, die dieselbe Domain-Einstellung hat wie die Clients, wenn sie jemandem einen Hinweis geben, warum dies geschieht und es periodisch passiert ... kein Reim oder Grund ... HTH - Dave


IISRESET hat das für mich behoben. Ich glaube, dass es der Lösung ähnelt, den SMTP-Dienst zurückzusetzen, da dieser Dienst von IIS abhängt. Nach dem Neustart verschwand die Mail in C: \ inetpub \ mailroot \ Queue!


1
2018-04-09 09:08





Meiner Erfahrung nach ist dies normalerweise darauf zurückzuführen, dass IIS SMTP versucht, einen temporären Fehler (4xx-Antwortcode) zu senden. Haben Sie die Protokollierung für den IIS SMTP-Dienst aktiviert und das Protokoll überprüft? Entschuldigung, wenn das alles offensichtlich ist, aber es ist schwer, die Ursache oder den Fehler zu kennen, ohne zu wissen, was das Log zeigt.


0
2018-01-15 01:02



Nicht offensichtlich. Ich weiß nicht viel über IIS etc .. [ich sollte], aber ich konzentriere mich hauptsächlich auf Code, nicht System-Admin-Zeug. Nicht einmal sicher, wie das Protokoll eingerichtet wird. - Jack Marchetti
Das einzige, was ich gesehen habe, ist folgendes: Aktion: fehlgeschlagen Status: 5.3.5 - Jack Marchetti
Um das Protokoll zu aktivieren, öffnen Sie den IIS 6-Administrator (auch wenn Sie IIS 7 verwenden, der SMTP-Dienst ist immer noch Teil von IIS 6), klicken Sie mit der rechten Maustaste auf die Eigenschaften des SMTP-Diensts, und wechseln Sie zur Registerkarte Protokollierung. Sie sollten in der Lage sein, das Protokoll zu aktivieren und / oder den Speicherort des Protokolls dort zu finden. - jlupolt


Ich denke, das Problem könnte sein, dass es auf dem System eine Verwechslung zwischen IPv4 und IPv6 gibt. Wenn Sie also localhost angeben, wird das Standard-IPv6-Protokoll gewählt. Ich hatte das gleiche Problem heute und es wurde behoben, nachdem Localhost Verweis auf IPv6-Adresse in Hosts wurde Hashed, obwohl das ein Zufall sein könnte (Ich bin auch SVN einrichten). Also hier ist mein Setup für den Fall:

  1. In IIS7 habe ich die Option "Deliver to SMTP server" aktiviert mit localhost als meinen ausgewählten Server.
  2. In IIS6 habe ich Zugriff auf nur 127.0.0.1, keine Authentifizierung für eingehende oder ausgehende festgelegt.

Ich habe den ganzen Tag mit den Einstellungen herumgespielt, also, um ehrlich zu sein, ich bin mir nicht sicher, was sonst die Tatsache beeinflusst haben könnte, dass es jetzt funktioniert. Hoffe, das hilft zumindest ein bisschen.


0
2017-09-28 13:49





Der erste Ort, an dem Sie suchen können, sind die Serverprotokolldateien. Dies wird Ihnen sagen, wenn Ihr Server Probleme beim Senden an bestimmte Hosts hat. Die meiste Zeit, in der dies passiert (in meinen Erfahrungen), ist es normalerweise DNS (entweder an Ihrem Ende oder remote), dass der Schuldige ist.


0
2018-01-15 18:28





Der SMTP-Server sucht nach einem SMTP-Host / Gateway, an den die E-Mail gesendet werden soll.

Wenn Sie versuchen, an localhost zu senden, wäre die Localhost-IP das Gateway. Wenn Sie versuchen, an eine externe E-Mail-Adresse wie gmail oder hotmail zu senden, müssen Sie das Mail-Gateway Ihres Internetdienstanbieters als Smarthost hinzufügen.

So richten Sie einen Smarthost ein:

  1. Klicken Sie im IIS-Manager mit der rechten Maustaste auf den virtuellen SMTP-Server, und klicken Sie dann auf Eigenschaften.
  2. Klicken Sie auf die Registerkarte Übermittlung, und klicken Sie auf Erweitert.
  3. Geben Sie in das Feld Smarthost den Namen des Smarthostservers ein. Sie können eine Zeichenfolge eingeben, um einen Namen darzustellen oder eine IP-Adresse einzugeben.
  4. Wenn der SMTP-Dienst versuchen soll, Remote-Nachrichten direkt zuzustellen, bevor sie an den Smarthost-Server weitergeleitet werden, aktivieren Sie das Kontrollkästchen Direkte Zustellung vor dem Senden an den Smarthost versuchen. Standardmäßig werden alle Remote-Nachrichten an den Smarthost gesendet, nicht um eine direkte Zustellung zu versuchen.

0
2018-04-01 15:33





Ich hatte das gleiche Problem nach dem Umschalten E-Mail-Dienst von einem Host zum anderen (neu ist Office 365). Nach vielen Versuchen hat es endlich damit angefangen:

  1. Fügen Sie meine E-Mail-Domäne zu IIS 6 als "Remote" -Domäne hinzu. (Dies ist die Domäne, die in O365 gehostet wird und alle Benutzerkonten verwenden.)
  2. Doppelklicken Sie in IIS 6 auf diese Domäne; Unter "Route Domain" wählen Sie "Alle E-Mails an Smarthost weiterleiten" und geben Sie Ihren Server ein (in meinem Fall "smtp.office365.com"). Aktivieren Sie außerdem das Kontrollkästchen "Zulassen, dass eingehende Nachrichten an diese Domäne weitergeleitet werden".
  3. Klicken Sie in IIS 6 mit der rechten Maustaste auf den virtuellen SMTP-Server> Eigenschaften.
    • Registerkarte Allgemein: Klicken Sie auf Erweitert und fügen Sie die IP-Adresse und den Port 587 Ihres lokalen Servers hinzu
    • Registerkarte Zugriff: Stellen Sie sicher, dass "TLS-Verschlüsselung erforderlich" aktiviert ist. Ich musste ein Domain-Zertifikat in IIS 7 mit dem Namen meiner E-Mail-Domäne erstellen.
    • Registerkarte Zugriff: Fügen Sie die IP-Adresse Ihres lokalen Servers zu den Listen "Verbindung" und "Relais" hinzu.
    • Übermittlungsregisterkarte: Ausgehende Sicherheit: Wählen Sie die Standardauthentifizierung aus und geben Sie die Anmeldeinformationen eines gültigen lizenzierten Benutzers ein. kreuzen Sie das Kästchen für "TLS-Verschlüsselung" an
    • Registerkarte Lieferung: Ausgehende Verbindungen: Geben Sie 587 für TCP-Port ein
    • Registerkarte Versand: Erweitert: Geben Sie Ihre E-Mail-Domäne als "Vollqualifizierten Domänennamen" und Ihren E-Mail-Server als "Smart-Host" ein (in meinem Fall smtp.office365.com).

Firewall: Ich habe gelesen, dass Sie Port 587 für Outbound öffnen müssen. (Ich habe nicht, weil dies ein VOIP-Server ist, der seine Firewall deaktiviert.)

Office 365: Fügen Sie unter Admin> Exchange einen "Connector" hinzu, um Ihre lokale statische IP-Adresse zuzulassen. Microsoft stellt diese Anweisungen online bereit.


0
2018-02-06 18:13