Frage Wie installiere ich eine rpm, die sich über rpmlib (FileDigests) <= 4.6.0-1 beschwert?


Ich versuche, eine RPM-Datei auf CentOS 5 zu installieren und bin mir nicht sicher, wie ich diese Probleme beheben kann:

$ rpm --install epel-release-6-5.noarch.rpm
warning: epel-release-6-5.noarch.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID 0608b895
error: Failed dependencies:
    rpmlib(FileDigests) <= 4.6.0-1 is needed by epel-release-6-5.noarch
    rpmlib(PayloadIsXz) <= 5.2-1 is needed by epel-release-6-5.noarch

Was bedeuten die Zeilen rpmlib (FileDigests) <= 4.6.0-1? ist RPMlib veraltet oder FileDigests veraltet? Was ist mit der Syntax von etwas, gefolgt von Klammern?

Ich habe versucht, yum zu verwenden, damit es Abhängigkeiten automatisch auflösen kann, aber es ist nicht möglich:

$ sudo yum --nogpgcheck install epel-release-6-5.noarch.rpm
...
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(FileDigests) is needed by epel-release-6-5.noarch
rpmlib(PayloadIsXz) is needed by epel-release-6-5.noarch
Complete!
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])

Auf dieser Seite https://bugzilla.redhat.com/show_bug.cgi?id=665073Sie sagen, dass meine Drehzahl veraltet ist, aber dann sage ich, dass ich eine RPM-Datei anfordern sollte, die mit meiner Version von rpm funktioniert (was 4.4.2.3 ist), aber das möchte ich nicht tun. Wie kann ich mein System mit dieser RPM-Datei kompatibel machen?

Bonuspunkte, wenn Sie mir sagen, wie ich den öffentlichen Schlüsselfehler beheben kann.


25
2018-06-13 23:57


Ursprung


Dies ist zwar nicht genau installieren ein Paket, könnte man zumindest ein Paket extrahieren und dann dessen Inhalt verwenden, ohne es zu installieren: rpm2cpio some-package.rpm | cpio -tv um seinen Inhalt aufzulisten und mit cpio -ivd um es zu extrahieren. - ckujau


Antworten:


Was ist mit der Syntax von etwas, gefolgt von Klammern?

Von http://jfearn.fedorapeople.org/en-US/RPM/0.1/html/RPM_Guide/ch-advanced-packaging.html:

Skriptsprachen wie Perl und   Tcl erlauben Add-On-Module. Ihre   Paket kann einige von diesen erfordern   Zusatzmodule. RPM verwendet ein spezielles   Syntax mit Klammern um anzuzeigen   Skriptmodulabhängigkeiten. Zum   Beispiel: Benötigt: perl (Karpfen)> = 3.2   Dies zeigt eine Voraussetzung für die   Carp-Zusatzmodul für Perl, größer   gleich oder gleich Version 3.2.

In diesem Fall bezieht es sich auf bestimmte Merkmale der rpm-Bibliothek.

Fehler: Fehlgeschlagene Abhängigkeiten:       rpmlib (FileDigests) <= 4.6.0-1 wird von epel-release-6-5.noarch benötigt       rpmlib (PayloadIsXz) <= 5.2-1 wird von epel-release-6-5.noarch benötigt

Dies deutet darauf hin, dass Sie versuchen, das zu installieren epel-release rpm auf einem System, für das es nicht entworfen wurde. In Ihrer Frage geben Sie an, dass Sie dies auf CentOS 5 installieren, während das Paket, das Sie installieren möchten, für CentOS 6 (oder RHEL 6) ausgelegt ist. Für CentOS 5 wollen Sie epel-release-5-4.noarch.rpm. Vielleicht möchten Sie das lesen EPEL-Dokumentation bevor du fortfährst, was diese Frage ebenso beantwortet hätte wie andere.

Ich habe versucht, yum zu verwenden, damit es Abhängigkeiten automatisch auflösen kann, aber es ist nicht möglich:

Richtig, denn diese Funktionen sind auf CentOS 5 nicht verfügbar. Aus der Perspektive von yum Du hast es nach magischen Einhörnern gefragt. Es kann keine finden.

Bonuspunkte, wenn Sie mir sagen, wie ich den öffentlichen Schlüsselfehler beheben kann.

Installieren Sie den EPEL-Signaturschlüssel. Wenn Sie die EPEL-Dokumentation lesen - es ist erstaunlich, was Sie dort finden - Sie erhalten einen Link zu https://fedoraproject.org/keysHier finden Sie Anweisungen zur Installation der vom Fedora-Projekt verwendeten öffentlichen Schlüssel.


29
2018-06-14 02:32



Das ist eine gute Antwort, viele Antworten, die klären. Schade um den Ton, der leicht snarky ist. Vielleicht ist dir die Lage des Landes klar, aber für mich ist alles noch immer von Nebel des Krieges bedeckt ... - Pieter Breed


Sie möchten EPEL Version 5.x (nicht 6.x).

http://download.fedoraproject.org/pub/epel/5/i386/epel-release-5-4.noarch.rpm

Sie betreiben CentOS 5. CentOS 6 ist noch nicht verfügbar.


7
2018-06-14 05:51





Der aktuelle rmp-Link, der auf CentOS 5.5 funktioniert hat, ist:

# rpm -ivh http://dl.fedoraproject.org/pub/epel/5/i386/epel-release-5-4.noarch.rpm

Handelt Abhängigkeiten automatisch.

Beachten Sie auch, dass es hilfreich sein kann, den Repost bei zB: http://dl.fedoraproject.org/pub/epel/5/i386/(/ 6 / i386 / etc) um die am besten geeignete Adresse zu finden.


4
2017-12-02 17:17





Das beste Kommando wird sein $ yum install epel-release und yum bekommt die richtige Drehzahl

Sie können die folgenden Befehle ausführen, um den öffentlichen Schlüsselfehler zu beheben.

$ yum clean all
$ yum makecache
$ yum update

0
2018-06-23 13:21





Mein Problem wurde in diesem Thread beschrieben: http://comments.gmane.org/gmane.linux.redhat.fedora.general/410408

Die Links in der Dokumentation sind Weiterleitungen, die (irgendwie?) Probleme mit dem Download verursachen. Hat gesagt, was der Thread gesagt hat und dann hat der Rest der EPEL-Dokumente ausgearbeitet.


-1
2017-10-13 00:52



Während dieser Link die Frage beantworten kann, ist es besser, hier die wesentlichen Teile der Antwort einzubeziehen und den Link als Referenz bereitzustellen. Nur-Link-Antworten können ungültig werden, wenn sich die verknüpfte Seite ändert. - Michael Hampton♦