Frage Samba-Konfiguration für öffentliche Freigaben


gestern habe ich meine fedora box auf die neueste version aktualisiert, und damit habe ich auch samba aktualisiert, jetzt mit samba 4. früher habe ich von jedem computer zu hause ohne user / passwort auf diese share zugegriffen, aber jetzt scheint da etwas nicht in Ordnung zu sein die Konfiguration.

Hier ist meine smb.conf

[global]
    workgroup = mygroup
    server string = Samba Server Version %v
    netbios name = HOME-WS
    log file = /var/log/samba/log.%m
    max log size = 50
    guest ok = yes
    security = share

[Media]
    path = /mnt/Media
    read only = yes
    browseable = yes
    guest ok = yes
    guest only = yes

[Music]
    path = /mnt/Music
    read only = yes
    browseable = yes
    guest ok = yes
    guest only = yes

Mit Blick auf die Protokolle gibt es eine Warnung bezüglich des Sicherheitsparameters

 WARNING: Ignoring invalid value 'share' for parameter 'security'

Bedeutet dies, dass Samba 4 die Option "Freigabe" als Option entfernt hat, gibt es eine Alternative dazu, so dass ich Freigaben ohne Passwort konfigurieren kann.


25
2018-01-19 17:11


Ursprung


Siehe den Abschnitt "Gastzugriff" unten auf dieser Seite. wiki.samba.org/index.php/Frequently_Asked_Questions - JasonAzze
Sie sind mein Held. Ich glaube nicht, dass irgendjemand mit nur 158 Ruf ein goldenes Abzeichen hat :). - Daniel


Antworten:


Wenn du dem FAQ-Link von JasonAzze folgst, wirst du sehen, dass es eine "map to guest" -Linie gibt, die auch benötigt wird, also brauchst du beide Zeilen:

security = user
map to guest = Bad Password

Ich hatte das gleiche Problem wie das OP, und ich habe getestet, dass diese Lösung auf Fedora 18 funktioniert


31
2018-03-31 02:20



Danke, hat super funktioniert! Von smb.conf man page: "(Zu Gast) Schlechter Benutzer - Bedeutet, dass Benutzeranmeldungen mit einem ungültigen Passwort abgelehnt werden, es sei denn, der Benutzername existiert nicht. In diesem Fall wird er als Gast-Login behandelt und dem Gastkonto zugeordnet. " In Verbindung mit einer "guest ok = yes" -Direktive unter einer Freigabe wird ein benutzer- / passwortloses Browsen ermöglicht. - joelpet
für Karte zu Gast "Bad User" ist besser: map to guest = Bad User - Benutzerlogins mit einem ungültigen Passwort werden abgelehnt, es sei denn, der Benutzername existiert nicht. In diesem Fall wird er als Gast-Login behandelt und dem Gastkonto zugeordnet. Wie die Manpage sagt (man smb.conf) Benutzer können durch die Option Bad Password verwirrt werden. - Matthew Hannigan


Ich fühle mich verpflichtet, dies zu teilen, nachdem ich stundenlang versucht habe, dies unter SAMBA4 zur Arbeit zu bringen - hier ist meine Arbeit SAMBA4 smb.conf, die kein Passwort benötigt, um von Windows auf die Freigabe zu gelangen

  [global]
  workgroup = HOME
  server string = %h server (Samba, Ubuntu)
  dns proxy = no
  log file = /var/log/samba/log.%m
  max log size = 1000
  syslog = 0
  panic action = /usr/share/samba/panic-action %d
  server role = standalone server
  security = user
  map to guest = Bad Password
  passdb backend = tdbsam
  obey pam restrictions = yes
  unix password sync = yes
  passwd program = /usr/bin/passwd %u
  passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:*        %n\n *password\supdated\ssuccessfully* .
  pam password change = yes
  usershare allow guests = yes

  # VIDEO SHARE
    [HD]
    comment = HD Video Share
    path = /RAID/HD
    public = yes
    writable = yes
    available = yes
    browsable = yes
    guest ok = yes
    create mask = 0777
    directory mask = 0777

7
2018-06-20 17:31



Danke fürs Teilen, aber ich kann es immer noch nicht schaffen. Vielleicht fehlt mir eine Verzeichnis-Berechtigung ... Windows fragt nicht mehr nach einem Passwort, sondern sagt, dass es keine Erlaubnis gibt, auf den freigegebenen Ordner zuzugreifen. - Edgar Carvalho
Sie müssen wahrscheinlich auch Ihren freigegebenen Ordner (in seinem Fall RAID / HD) oder chmod so, dass es global lesbar und eXecutable (chmod o + rX / Ihre / dir) - Warren P


Ändern Sie "security = share" in "security = user"

Grund: Sowohl share als auch server sind in Samba4 veraltet.


3
2018-02-06 03:40





Ich musste daran denken, noch etwas anderes zu tun, bevor ich das zum Laufen bringen konnte ... es war sicherzustellen, dass die Berechtigungen für mein freigegebenes Unix-Verzeichnis für den Benutzer nobody oder die Gruppe nogroup gelesen / geschrieben wurden. Debian Jessie, Samba 4.1.


2
2017-10-19 20:46



Wie genau machst du das? Was zum Teufel ist die nobodyuser / noblegroup? - Warren P