Frage Warum verhindert dies die Installation eines MSI: Der Systemadministrator hat Richtlinien festgelegt, um diese Installation zu verhindern


Ich versuche, ein MSI auf einem Windows Server 2012-Computer zu installieren, der Teil meiner Lab-Domäne ist. Ich bin lokaler und Domänenadministrator, aber ich scheine davon abgehalten zu werden, dieses MSI zu installieren.

Zur Verdeutlichung, wenn Sie versuchen, die Git-Erweiterung für Visual Studio zu installieren (befindet sich Hier) Als Domänenbenutzer angemeldet, der Teil der Administratorgruppe ist, erhalte ich den folgenden Fehler

enter image description here 

Die Maschine, die den Fehler meldet, ist ein Windows Server 2012.

Ich bin mir fast sicher, dass es eine Art Gruppenrichtlinienbeschränkung sein muss? Es wurde keine festgelegt, außer es ist die Standardsicherheitsstufe.

Zur Klarstellung möchte ich es wissen Was verhindert, dass dieses MSI von einem Domänenadministrator installiert wird?


26
2018-03-10 09:23


Ursprung




Antworten:


Nachdem ich mich mit der Gruppenpolitik beschäftigt hatte, gab es, soweit ich das beurteilen konnte, nichts Relevantes. Ich bin dann gestolpert dieser Beitrag das schlägt vor, dass ich versuche, einen Befehl als Administrator zu starten und zu starten

 msiexec /a install.msi

Dies schien zu funktionieren, aber lief sehr schnell - Tatsächlich tat es das nicht. Ich habe es aus einer Laune heraus in der Admin-Eingabeaufforderung versucht.

 msiexec /i install.msi

was ein Leckerbissen war.


35
2018-03-10 20:06



Das funktioniert, aber es kann ärgerlich sein, es bei jeder Installation von einer MSI zu tun. Siehe Armin Sadeghi's Antwort unten für eine langfristige Lösung. - Jake


Ich bin auf dieses Verhalten gestoßen, wo MSI-Installation mit "Der Systemadministrator hat Richtlinien, um diese Installation zu verhindern" zuvor verhindert wurde. Ich glaube, dass dies auf die Windows-Softwareeinschränkungsrichtlinie zurückzuführen ist, und ich habe sie sowohl auf Windows Server 2008 R2 als auch auf Windows Server 2012 gesehen.

Es gibt wahrscheinlich eine bessere GUI-basierte Methode, um die Richtlinie zu ändern, aber den folgenden reg-Schlüssel als Administrator auf der Maschine zu setzen, macht den Trick:

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
"DisableMSI"=dword:00000000

13
2018-04-15 06:59



Das funktioniert 100% - Jan Chrbolka
Das hat für mich funktioniert. Ich musste den "Installer" -Teil des Pfades als Schlüssel hinzufügen und dann das DWORD "DisableMSI" (ohne die Anführungszeichen) hinzufügen. - Mike S


Dies ist normalerweise auf eine Gruppenrichtlinie oder eine lokale Richtlinie zurückzuführen, die Windows Installer deaktiviert.

Suchen Sie auf Ihrem Domänencontroller nach einem Gruppenrichtlinienobjekt, das "Windows Installer" deaktiviert: Computerkonfiguration> Administrative Vorlagen> Windows-Komponenten> Windows Installer> "Windows Installer deaktivieren".

Stellen Sie sicher, dass es auf "Nicht konfiguriert" oder "Deaktiviert" eingestellt ist.

Wenn Sie es in Ihren Gruppenrichtlinienobjekten nicht finden, sehen Sie sich die lokalen Richtlinien des Computers mit gpedit.msc an.

Hinweis: Die Tatsache, dass Sie Domainadministratoren sind, spielt keine Rolle. Alles hängt vom Umfang des Gruppenrichtlinienobjekts ab.


2
2017-07-15 21:25



Verify that it is set to "Not configured" or "Disabled". Das ist nicht wahr. Der Standardwert (Nicht konfiguriert) ist 1 was bedeutet managed only. msdn.microsoft.com/en-us/library/aa368304.aspx Deaktiviert in Bezug auf gpos bedeutet, dass die Richtlinie deaktiviert wird, sodass der Registrierungsschlüssel gelöscht und der Standardwert verwendet wird. Sound ist seltsam, aber Sie müssen wählen Enabled und wählen Sie Never in dem Dropdown-Feld. - Jürgen Steinblock


Wir hatten genau das gleiche Problem beim Erstellen eines MSI mit IsCmdBld.exe, aber nicht beim Erstellen über die Benutzeroberfläche der InstallShield-Software.

Wenn wir das Installationsprogramm ausführen, sehen wir den vom OP erwähnten Fehler und das Installationsprotokoll würde folgendes anzeigen: MSI_LUA: Invalid Descriptor Format.

Die Ursache des Problems war, dass wir einen ProductCode Guid-Wert wie folgt an die IsCmdBld.exe-Befehlszeile übergeben: -z "ProductCode"="f176c219-dec0-4fa9-a373-94a711f28a3d".

Sie können sehen, dass das hier bereitgestellte Guid nicht von { und }.

Wir haben es behoben, indem wir die Guid mit Klammern umgeleitet haben: -z "ProductCode"="{f176c219-dec0-4fa9-a373-94a711f28a3d}" was wie erwartet funktioniert und den Fehler nicht mehr anzeigt.


1
2018-06-11 20:48





Rechtsklick -> Als Administrator ausführen


0
2017-10-26 18:17



Wie ist das anders als akzeptierte Antwort? - Dave M


Weder die msiexec - noch die Registry - Fixes funktionierten für mich (auch nach dem Neustart), aber die Benutzerkontensteuerung wurde deaktiviert (wie von Ha Ly im Dieser Thread) und Neustart hat den Trick gemacht.


0
2017-08-25 22:58





Sie können die Benutzerkontensteuerung über die Registrierung deaktivieren, indem Sie die DWORD  EnableLUA von 1 zu 0 im HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\system. Sie erhalten eine Benachrichtigung, dass ein Neustart erforderlich ist. Nach dem Neustart ist die Benutzerkontensteuerung deaktiviert.


-2
2018-06-02 15:09