Frage glusterfs: Die 'Volume-Datei' konnte nicht vom Server abgerufen werden


Ich habe ein GlusterFS-Volume gehostet auf einem Remote-Fileserver. Ich kann das Volume von meinen Webservern im selben DC wie auch von anderen Servern in anderen Domänencontrollern mounten, aber wenn ich versuche, das Volume auf meinem lokalen Entwicklungsserver zu mounten, schlägt der Mount mit dem folgenden Protokolleintrag fehl:

[2015-02-04 15:02:56.034956] I [MSGID: 100030] [glusterfsd.c:2018:main] 0-/usr/sbin/glusterfs: Started running /usr/sbin/glusterfs version 3.6.2 (args: /usr/sbin/glusterfs --volfile-server=eros --volfile-id=/storage /var/storage)
[2015-02-04 15:02:56.065574] E [glusterfsd-mgmt.c:1494:mgmt_getspec_cbk] 0-glusterfs: failed to get the 'volume file' from server
[2015-02-04 15:02:56.065650] E [glusterfsd-mgmt.c:1596:mgmt_getspec_cbk] 0-mgmt: failed to fetch volume file (key:/storage)
[2015-02-04 15:02:56.065889] W [glusterfsd.c:1194:cleanup_and_exit] (--> 0-: received signum (0), shutting down
[2015-02-04 15:02:56.065905] I [fuse-bridge.c:5599:fini] 0-fuse: Unmounting '/var/storage'.
[2015-02-04 15:02:56.081713] W [glusterfsd.c:1194:cleanup_and_exit] (--> 0-: received signum (15), shutting down

Ich habe überprüft, dass die Firewall die Pakete nicht blockiert, alle Maschinen führen die gleiche Version von GlusterFS aus dem gleichen Repo und ich kann Telnet zu den Gluster-Ports vom lokalen Server, aber ich kann das Volume immer noch nicht anhängen Maschinen in meinem lokalen Netzwerk.

Irgendwelche Vorschläge würden sehr geschätzt werden.


5
2018-02-04 15:18


Ursprung




Antworten:


Sie müssen den VOLUMENNAMEN im Befehl mount angeben, nicht den PATH.


9
2018-03-11 18:21





Wenn du bist nicht mit RPM-Paketen ist es möglich, dass dieser Fehler auftritt: https://bugzilla.redhat.com/show_bug.cgi?id=1191176

Die Namen von volfiles auf der Festplatte wurden geändert, um die Unterstützung von rdma zu verbessern.   Diese Änderung wurde in 3.6.2 eingeführt.

Stoppen Sie glusterd, run glusterd --xlator-option *.upgrade=on -N um die volfiles zu regenerieren, starte glusterd (auf allen Knoten).


5
2018-05-20 13:14





Ich hatte das gleiche Problem und dieser Befehl hilft mir:

gluster volume sync <HOSTNAME> [all|<VOLNAME>] - sync the volume information from a peer


-1
2018-04-15 09:44