Frage nginx + php-fpm - wo sind meine $ _GET-Parameter?


Ich habe hier ein seltsames Problem. Ich bin gerade von apache + mod_php nach nginx + php-fpm gewechselt. Alles ging gut außer diesem einen Problem.

Ich habe eine Website, sagen wir beispiel.com. Wenn ich darauf zugreife mag example.com?test=get_param  $_SERVER['REQUEST_URI'] ist /?test=get_param und da ist ein $_GET['test'] ebenfalls.

Aber wenn ich zugreife example.com/ajax/search/?search=get_param  $_SERVER['REQUEST_URI'] ist /ajax/search/?search=get_param dennoch gibt es kein $_GET['search'] (es gibt kein $_GET Array überhaupt).

Ich benutze Kohana Framework. welche Routen /ajax/search zum Controller, aber ich habe gesagt phpinfo() beim index.php also suche ich nach $_GET Variablen vor Framework tut alles (das bedeutet, dass Disapearing Params sind keine Frameworks Fehler).

Meine nginx.conf ist so

worker_processes  4;
pid        logs/nginx.pid;
events {
    worker_connections  1024;
}
http {
    index index.html index.php;
    autoindex on;
    autoindex_exact_size off;
    include       mime.types;
    default_type  application/octet-stream;
    server_names_hash_bucket_size 128;
    log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';

    access_log  logs/access.log  main;
    error_log   logs/error.log   debug;

    sendfile        on;
    tcp_nopush      on;
    tcp_nodelay     off;

    keepalive_timeout  2;

    gzip  on;
    gzip_comp_level 2;
    gzip_proxied any;
    gzip_types text/plain text/css application/x-javascript text/xml application/xml     application/xml+rss text/javascript;


    include sites-enabled/*;
}

und example.conf ist so

server {
  listen 80;
  server_name www.example.com;
  rewrite ^ $scheme://example.com$request_uri? permanent;
}




server {
    listen   80;
    server_name example.com;
    root /var/www/example/;

    location ~ /\. {
        return 404;
    }

    location / {
        try_files $uri $uri/ /index.php;
    }

    location ~ \.php$ {
        fastcgi_pass   127.0.0.1:9000;
        fastcgi_index  index.php;
        fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;
        include        /usr/local/nginx/conf/fastcgi_params;
    }

    location ~* ^/(modules|application|system) {
        return 403;
    }

        # serve static files directly
        location ~* ^.+.(jpg|jpeg|gif|css|png|js|ico|html|xml|txt)$ {
                access_log        off;
                expires           30d;
        }
}

fastcgi_params ist so

fastcgi_param  QUERY_STRING       $query_string;
fastcgi_param  REQUEST_METHOD     $request_method;
fastcgi_param  CONTENT_TYPE       $content_type;
fastcgi_param  CONTENT_LENGTH     $content_length;

fastcgi_param  SCRIPT_NAME        $fastcgi_script_name;
fastcgi_param  REQUEST_URI        $request_uri;
fastcgi_param  DOCUMENT_URI       $document_uri;
fastcgi_param  DOCUMENT_ROOT      $document_root;
fastcgi_param  SERVER_PROTOCOL    $server_protocol;

fastcgi_param  GATEWAY_INTERFACE  CGI/1.1;
fastcgi_param  SERVER_SOFTWARE    nginx/$nginx_version;

fastcgi_param  REMOTE_ADDR        $remote_addr;
fastcgi_param  REMOTE_PORT        $remote_port;
fastcgi_param  SERVER_ADDR        $server_addr;
fastcgi_param  SERVER_PORT        $server_port;
fastcgi_param  SERVER_NAME        $server_name;

# PHP only, required if PHP was built with --enable-force-cgi-redirect
fastcgi_param  REDIRECT_STATUS    200;


fastcgi_connect_timeout 60;
fastcgi_send_timeout 180;
fastcgi_read_timeout 180;
fastcgi_buffer_size 128k;
fastcgi_buffers 4 256k;
fastcgi_busy_buffers_size 256k;
fastcgi_temp_file_write_size 256k;
fastcgi_intercept_errors on;


fastcgi_param QUERY_STRING    $query_string;
fastcgi_param PATH_INFO       $fastcgi_path_info;

Was ist das Problem hier?

Übrigens gibt es ein paar mehr Seiten auf dem gleichen Server, sowohl auf Kohana-based als auch auf normalem php, die perfekt funktionieren.


33
2018-02-05 15:02


Ursprung




Antworten:


Sie übergeben keine Argumente in Ihrem try_files Anruf

in der Frage:

location / {
    try_files $uri $uri/ /index.php;
}

Sollte sein:

location / {
    try_files $uri $uri/ /index.php?$query_string;
}

Sie können beides verwenden $ query_string oder $ Argumente, sie sind gleichwertig - außer $query_string ist readonly (oder alternativ $args kann durch jede andere Logik aktualisiert werden, die Sie hinzufügen möchten)


69
2018-02-23 08:41



+1 Slim's eigene Dokumentation ist falsch. - Brodie
^ dito; Stunden damit verbracht, das elende Ding für ein anderes Projekt zu sortieren. Danke ad7six. - Rijndael
Aus der neuesten Slim3-Dokumentation: try_files $uri $uri/ /index.php$is_args$args; - mixdev
Was ist, wenn wir php-fpm anstelle von fastcgi verwenden? Wir können die Konfiguration in fastcgi.conf nicht verwenden, um den Variablennamen "$ query_string" abzurufen. - NaturalBornCamper


Teste meine Regeln:

location / {
    try_files $uri $uri/ @koh;
}

location @koh {
    fastcgi_pass   127.0.0.1:9000;
    fastcgi_index  index.php;
    fastcgi_param  SCRIPT_FILENAME  /var/www/example/index.php;
    include        /usr/local/nginx/conf/fastcgi_params;
}

Löschen Sie auch duplicated "fastcgi_param QUERY_STRING" in fastcgi_params.


1
2018-02-05 16:14



Dies funktioniert nicht. Auf ajax/search es gibt 500 Fehler, auf example.com erscheint das Download-Fenster und die heruntergeladene Datei ist index.php - egis
Wie auch immer, ich habe eine Antwort gefunden, try_files $uri $uri/ index.php; muss sein try_files $uri $uri/ /index.php?$args; #or /index.php?$query_string, mind the '?', aber es wäre schön, dass jemand das erklärt :) - egis
BTW, Fehlerprotokoll für Ihre Konfiguration, sagt Alvosu could not find named location @koh. - egis
Sorry, mir wurde ein Fehler unterlaufen. Ich korrigierte "Standort". - alvosu


location / {
   try_files $uri $uri/ /index.php$is_args$args;
}

1
2018-02-27 17:11