Frage IIS Manager - Verbindung zu einem anderen Server (Win7 zu Win2008 Server)


Ich verwende Windows 7 Ultimate. Wenn ich den IIS-Manager öffne, sehe ich auf der linken Seite eine Liste mit "Verbindungen". In früheren Versionen war ich in der Lage, eine Option auszuwählen, um sich mit einem anderen Server zu verbinden oder mit einem anderen Computer zu verbinden, aber diese Option ist nirgendwo sichtbar. Die einzige Sache in der Liste ist meine lokale Maschine.

Selbst wenn ich den Serverstandort manuell in die Adresszeile eintippe (\ Servername, auch nur Servername versucht), passiert nichts (es wird einfach auf meinen aktuellen lokalen Computer zurückgesetzt)

Die Dokumentation unter http://technet.microsoft.com/en-us/library/cc732466%28WS.10%29.aspx scheint die gleichen Schritte implizieren ... aber es gibt einfach keine Taste oder Menüoption, um dies zu tun. Fehle ich etwas? Ich sehe nicht einmal eine ausgegraute Menüoption.

BEARBEITEN: Unter dem Menü "Datei" sehe ich 2 Optionen:

  • Verbindungen speichern (ausgegraut)
  • Ausgang

alt text

Unter dem Bereich "Verbindungen" sehe ich eine Schaltfläche ausgegraut. Wenn ich die Maus halte, sagt es einfach "Up", scheint benutzbar zu sein, wenn ich ein Element in den IIS-Einstellungen meiner lokalen Computer suche

Wenn ich mit der rechten Maustaste in das Fenster klicke, sehe ich

  • Aktualisierung
  • Website hinzufügen (zum aktuellen Gastgeber)
  • Start
  • Halt
  • Umbenennen
  • Wechseln Sie zur Inhaltsansicht

alt text

UPDATE: Ich habe die Remote Server Administration Tools heruntergeladen und installiert http://www.microsoft.com/downloads/details.aspx?FamilyID=7D2F6AD7-656B-4313-A005-4E344E43997D&displaylang=enund ich habe es aktiviert alles aufgeführt unter "Remote Server-Verwaltungstools" unter "Windows-Funktionen ein- oder ausschalten". Immer noch nichts.


36
2018-02-24 20:07


Ursprung


@Matt - Ich habe das gleiche Problem. Ich habe mir die Freiheit genommen, Bilder hinzuzufügen; hoffe, das ist OK. Win 7 Enterprise, 32-Bit, Benutzerkontensteuerung deaktiviert. - p.campbell
@ pcampbell Danke !! Ich habe tatsächlich versucht, Screenshots zu machen, aber alt-printscreen würde dazu führen, dass die Menüs vor dem Screenshot weggehen, und ich hatte keine Software, die praktisch ist, um das zu tun. - Matt
@ pcampbell Überprüfen Sie meine Antwort unten ... das Problem gefunden - Matt
Kurs, jetzt bekomme ich Zugriff verweigert Fehler (401) beim Versuch, eine Verbindung herzustellen, obwohl ich "Remote-Verbindungen aktiviert haben" mit "Windows-Anmeldeinformationen nur" ... aber ich denke, das ist ein anderes Problem - Matt


Antworten:


Es stellte sich heraus, dass ich den "IIS-Manager für die Remote-Verwaltung" installieren musste, der unter (http://www.ip-phone-forum.de/showthread.php?t=86992) diskutiert wird (und zum Download verfügbar ist) http://www.iis.net/expand/IISManager. Warum ist dies nicht Teil der Windows 7 "Remote Administration Tools" Ich bin mir nicht sicher. Aber nach der Installation bekomme ich die zusätzlichen "connect" Optionen.


43
2018-02-24 22:07



Ich habe deine Antwort nicht gesehen, bevor ich meine gepostet habe. Gut für dich, dass du die Lösung gefunden hast. - Luke99
Ich habe bereits IIS-Manager für Remote-Verwaltung installiert, aber ich habe das gleiche Problem, als ich vor wenigen Tagen nicht war. Ich habe jedoch versucht, IIS für RA neu zu installieren nochmal aber jetzt sagt es mir, dass es nicht mit meinem System kompatibel ist (ich kann mich nicht an die genaue Nachricht erinnern, aber was auch immer) - delete me


In Windows 8 (oder Windows 7) können Sie die Webplattform-Installer Installieren Sie den IIS-Manager für die Remoteverwaltung. Es ist unter 2 MB.

enter image description here

Die neueste Version sollte verfügbar sein.

enter image description here


2
2017-08-20 20:46





Versuchen Sie im IIS-Manager, zu Datei-> Verbinden mit einem Server gehen. Du sagst das ist nicht da?


0
2018-02-24 20:10



Das ist richtig. Unter Datei sehe ich 2 Optionen, 1) Ein ausgegrautes "Speichern von Verbindungen", und beenden. - Matt


Haben Sie versucht, den IIS-Manager als Administrator auszuführen? Sie müssen sich bei einem Administrator befinden, um eine Remote-Verbindung zu einem Server über den IIS-Manager herzustellen.


0
2018-02-24 20:31



Sobald du das gesagt hast, dachte ich "das Muss sei das Problem ". Ach, kein Glück. Interessanterweise, wenn ich auf" run as administrator "klicke, werde ich nicht wie andere Programme aufgefordert, wenn ich versuche, als Administrator zu laufen. Ich dachte, dass es von etwas angefangen hat Im Speicher von früheren Einführungen gespeichert, so dass ich komplett neu gestartet, und es mich immer noch nicht aufgefordert, die App als Admin zu genehmigen. - Matt
Sehen Sie sich diesen Link an - er hilft Ihnen, Ihre Tools für den Remote-Administrator über den IIS-Manager zu aktivieren. lernen.iis.net/page.aspx/159/... - Brian Knight
Die erste Hälfte davon ist für den Zielcomputer ... wenn es schließlich erläutert, wie die Verbindung initiiert wird, heißt es "Klicken Sie im IIS-Manager auf Datei und dann auf Mit einem Standort verbinden (oder mit einer Anwendung verbinden)" Was fehlt mir? Ihr Bildschirm sieht anders aus (hat mehr Tasten), als ich sehe. - Matt


Haben Sie versucht, nach den IIS-Remote-Administrationstools zu suchen - daran musste ich mich bei der Fernverwaltung von 2008-Boxen gewöhnen.


0
2018-02-24 20:54



Ist das nicht der IIS-Manager? - Matt
Nicht sicher, denn es ist schon eine Weile her, seit ich auf 2008 geschaut habe - diese sind gut? - microsoft.com/downloads/ ... - Jon
Habe es geschossen (aktualisierte Frage) - kein Glück. Sogar eingeschaltet jedenFeature in "Windows Features ein- oder ausschalten -> Remote Admin Tools" - Matt


Ich musste das Remote-Verwaltungstool von IIS installieren (wie von Matt angegeben und von mehreren anderen vorgeschlagen). Nach der Installation stieß ich jedoch auf das gleiche Problem, das Matt aufzählte: Als ich versuchte, mich mit den Sites zu verbinden, bekam ich immer eine 401-Fehlermeldung.

Ich habe einen kompletten Neustart des Systems durchgeführt. Als ich mich wieder im System anmeldete und dann erneut das IIS-Remoteverwaltungstool ausprobierte, konnte ich mich diesmal mit der externen Site verbinden. Ich bin mir nicht sicher, ob der Neustart das Problem gelöst hat oder ob es etwas anderes war, aber hoffentlich hilft das einem anderen, der das gleiche Problem hat.


0
2018-05-21 13:23





Ich dachte nur, ich würde die Leute meine Erfahrung wissen lassen. Ich hatte bereits "IIS Manager für Remote Administration", aber ich war auch mit den OPs Screenshots fest. Keine Verbindung oder Hinzufügen neuer Verbindungen usw.

Mein Problem war, dass ich mit meinem Upgrade auf Windows 10 etwas "aus" war. Ich habe die Option "Reparieren" ausgeführt und dadurch mein Problem gelöst.


0
2018-02-10 17:19





01/01/2018: Konnte nicht installieren IIS-Manager für die Remoteverwaltung v1.2 über die Web-Plattform-Installer (Web-PI). Der Web-PI ist durchgehend fehlgeschlagen und hat darauf hingewiesen, dass die heruntergeladene Datei möglicherweise manipuliert wurde.

Stattdessen musste ich durch diese Seite gehen, um sie herunterzuladen und zu installieren: https://www.microsoft.com/en-us/download/details.aspx?id=41177


0
2018-01-01 23:27